<!doctype html>
<html lang="en" class="no-js">
<head>
<meta charset="utf-8">
<title>Saturday Nations League Bet Builder Tips - Germany can handle Italian job</title>
<link rel="preconnect" href="//betting.cdnppb.net" crossorigin>
<link rel="preconnect" href="//www.googletagmanager.com" crossorigin>
<link rel="preconnect" href="//ajax.googleapis.com" crossorigin>
<link rel="preconnect" href="//www.google-analytics.com" crossorigin>
<link rel="preconnect" href="//connect.facebook.com" crossorigin>
<link rel="preconnect" href="//servedby.flashtalking.com" crossorigin>
<link rel="preconnect" href="//cdn-ukwest.onetrust.com" crossorigin>
<link rel="preconnect" href="//s0.2mdn.net" crossorigin>
<link rel="preload" href="//ajax.googleapis.com/ajax/libs/jquery/3.5.1/jquery.min.js" as="script">
<link rel="preload" href="//betting.cdnppb.net/_v2/img/webfonts/Noto/Medium/NotoSans-Medium.woff" as="font" type="font/woff" crossorigin>
<link rel="preload" href="//betting.cdnppb.net/_v2/img/webfonts/Noto/Bold/NotoSans-Bold.woff" as="font" type="font/woff" crossorigin>
<link rel="preload" href="//betting.cdnppb.net/_v2/img/webfonts/Noto/BoldItalic/NotoSans-BoldItalic.woff" as="font" type="font/woff" crossorigin>
<link rel="preload" href="//betting.cdnppb.net/_v2/img/webfonts/Noto/ExtraBold/NotoSans-ExtraBold.woff" as="font" type="font/woff" crossorigin>
<link rel="preload" href="//betting.cdnppb.net/_v2/img/webfonts/Noto/ExtraBoldItalic/NotoSans-ExtraBoldItalic.woff" as="font" type="font/woff" crossorigin>
<link rel="preload" href="//betting.cdnppb.net/_v2/img/betfair-icon.svg" as="image"> <link rel="preload" href="//betting.cdnppb.net/_v2/img/backgrounds/bf-triangle-down.png" as="image">
<link rel="preload" href="//betting.cdnppb.net/_v2/img/backgrounds/bf-triangle-up.png" as="image">
<link rel="preload" href="//betting.cdnppb.net/_v2/img/spritesheets/icons-v2.svg" as="image"> <link rel="preload" href="//betting.cdnppb.net/_v2/bf.css?v=ec6a41b12e53791b84c1dca1acc70026" as="style">
<link rel="preload" href="//betting.cdnppb.net/_v2/bf-v2-body.js?v=ac199e7db677bb9e37ee459599bc841c" as="script">
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="theme-color" content="#FFB80C">
<meta name="description" content="Germany are in fine form under new management and Dan Fitch thinks they will get a positive result against struggling Italy, as he picks Bet Builders for Saturday&#039;s Nations League ties.">
<meta name="keywords" content="">
<link rel="canonical" href="https://betting.betfair.com/football/uefa-nations-league/saturday-nations-league-bet-builder-tips-germany-can-handle-italian-job-020622-629.html">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@BetfairExchange">
<meta name="twitter:creator" content="@djfitch">
<meta name="twitter:title" content="Saturday Nations League Bet Builder Tips: Germany can handle Italian job">
<meta name="twitter:description" content="Germany are in fine form under new management and Dan Fitch thinks they will get a positive result against struggling Italy, as he picks Bet Builders for Saturday&#039;s Nations League ties.">
<meta name="twitter:image" content="https://betting.cdnppb.net/football/Flick150321.jpg">
<meta property="og:url" content="https://betting.betfair.com/football/uefa-nations-league/saturday-nations-league-bet-builder-tips-germany-can-handle-italian-job-020622-629.html" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Saturday Nations League Bet Builder Tips: Germany can handle Italian job" />
<meta property="og:description" content="Germany are in fine form under new management and Dan Fitch thinks they will get a positive result against struggling Italy, as he picks Bet Builders for Saturday&#039;s Nations League ties." />
<meta property="og:image" content="https://betting.cdnppb.net/football/Flick150321.956x538.jpg" />
<meta property="og:mainEntityOfPage" content="https://betting.betfair.com/football/uefa-nations-league/saturday-nations-league-bet-builder-tips-germany-can-handle-italian-job-020622-629.html" />
<meta property="og:dateModified" content="2022-06-02T15:57:00+01:00" />
<meta name="original-source" content="https://betting.betfair.com/football/uefa-nations-league/saturday-nations-league-bet-builder-tips-germany-can-handle-italian-job-020622-629.html">
<link rel="amphtml" href="https://betting.betfair.com/football/uefa-nations-league/saturday-nations-league-bet-builder-tips-germany-can-handle-italian-job-020622-629.html?amp=1">
<link rel="alternate" type="application/rss+xml" title="UK RSS" href="https://betting.betfair.com/index.xml" /><link rel="alternate" type="application/rss+xml" title="Football UK RSS" href="https://betting.betfair.com/football/index.xml" /><link rel="alternate" type="application/rss+xml" title="UEFA Nations League RSS" href="https://betting.betfair.com/football/uefa-nations-league/index.xml" /> <link rel="shortcut icon" href="//betting.cdnppb.net/_v2/img/app-icons/favicon.ico">
<link rel="apple-touch-icon" sizes="76x76" href="//betting.cdnppb.net/_v2/img/app-icons/76.png">
<link rel="apple-touch-icon" sizes="120x120" href="//betting.cdnppb.net/_v2/img/app-icons/120.png">
<link rel="apple-touch-icon" sizes="152x152" href="//betting.cdnppb.net/_v2/img/app-icons/152.png">
<link rel="apple-touch-icon" sizes="180x180" href="//betting.cdnppb.net/_v2/img/app-icons/180.png">
<script>
  document.documentElement.className = document.documentElement.className.replace('no-js', 'js');
  var isBig = (screen.width >= 768) ? true : false;
  var ASSET_DOMAIN = 'betting.cdnppb.net';
  var ui = {
    menu_text: ''
  };
  var contextual_info = '{"blog_name":"Football UK","category_label":"UEFA Nations League","market_id":"https:\/\/www.betfair.com\/sport\/football\/uefa-nations-league\/italy-v-germany\/31280487","entry_title":"Saturday Nations League Bet Builder Tips: Germany can handle Italian job"}';
</script>
<script>

  // Usage: ga_pageLoad('property', 'locale', 'jurisdiction', 'platform', 'product_key')

  window.getCookie = function (name) {
    var match = document.cookie.match(new RegExp('(^| )' + name + '=([^;]+)'));
    if (match) return match[2];
  };

	function ga_pageLoad(property, locale, jurisdiction, platform, product_key, vertical) {
		if (typeof product_key === 'undefined') {
			product_key = 'bf';
		}

		if (typeof vertical === 'undefined') {
			vertical = 'exchange';
		}

    var product = [product_key, 'blog', locale, platform].join(' ');
    
    // Oritentation
    var orientation = 'desktop';
		if (platform != 'desktop') {
			orientation = (window.matchMedia("(orientation: portrait)").matches ? 'portrait' : 'landscape');
		}

    // Reg status
    var reg_status = 'unregistered', 
				bsfd_st = '',
				bsfd = getCookie('bsfd');
		if (bsfd) {
    	bsfd_st = bsfd.substring(bsfd.indexOf('|') + 1);
		}

    switch (bsfd_st) {
      case 'reg':
        reg_status = 'returning registered';
        break;
      case 'p':
        reg_status = 'new prospect';
        break;
      case 'rp':
        reg_status = 'returning';
        break;
      default:
        reg_status = 'unregistered';
    }

    // Payload
		window.dataLayer = window.dataLayer || [];
		dataLayer.push({
			'event': 'ga_pageLoad',
			'ga_target_property': property,
			'acc_id': null,
			'vertical': vertical,
			'product': product,
			'locale': locale,
			'reg_status': reg_status,
			'login_status': "logged out",
			'jurisdiction': jurisdiction,
			'orientation': orientation,
			'app_id': null,
			'rfr': getCookie('rfr'),
			'pid': getCookie('pid'),
			'ttp': getCookie('ttp'),
			'bid': getCookie('bid'),
			'promo_code': getCookie('promotionCode'),
			'clkid': getCookie('clkID'),
			'sid': getCookie('sid'),
			'StickyTags': getCookie('StickyTags'),
			'TrackingTags': getCookie('TrackingTags'),
			'brand': product_key,
			'vid': getCookie('vid')
		});
	};
</script> <link rel="stylesheet" href="//betting.cdnppb.net/_v2/bf.css?v=ec6a41b12e53791b84c1dca1acc70026" /> <script src="//ajax.googleapis.com/ajax/libs/jquery/3.5.1/jquery.min.js"></script>
<script src="//betting.cdnppb.net/_v2/bf-v2-body.js?v=ac199e7db677bb9e37ee459599bc841c"></script>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.defer=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-P32JX6');</script>

<link rel="manifest" href="/manifest.json">
<meta name="apple-itunes-app" content="app-id=1084818519" />
<meta property="fb:app_id" content="1993283457561753" />
<meta property="fb:pages" content="106600595002" />
<meta property="fb:admins" content="adam.baylis" />
<meta property="fb:admins" content="joe.dyer.9250" />
<meta property="fb:admins" content="michael.norman.543" />
<meta name="google-site-verification" content="2WO_m3dA936nmysauyp7GaqR63a-qUMcxv8lwa-eQy0" />
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-43334570-1', 'betfair.com');

// Mobile only exchange
if (!isBig) {
  ga('create', 'UA-43334570-2', 'betfair.com', 'mobile');
}

// create the dataLayer array
window.dataLayer = window.dataLayer || []

// start additional code. ensure dataLayer code is above this
ga(function(tracker) {

  // Grab a reference to the default sendHitTask function.
  var originalSendHitTask = tracker.get('sendHitTask');

function getPayloadObject(payload) {
    var match,
        pl     = /\+/g,  // Regex for replacing addition symbol with a space
        search = /([^&=]+)=?([^&]*)/g,
        decode = function (s) { return decodeURIComponent(s.replace(pl, " ")); },
        query  = payload;

    var urlParams = {};
    while (match = search.exec(query))
       urlParams[decode(match[1])] = decode(match[2]);

    return urlParams;
};

  // Modifies sendHitTask to send a copy of the request to window.dataLayer

  tracker.set('sendHitTask', function(model) {
    // sending the normal request to www.google-analytics.com/collect.
    originalSendHitTask(model);

    // sending the payload to the datalayer
    var payload = model.get('hitPayload');
    var payloadObject = getPayloadObject(payload)

    payloadObject.event = payloadObject.t == 'event' ? 'googleAnalyticsEvent' : 'googleAnalyticsPageview';
    window.dataLayer.push(payloadObject);
  });
});

// send pageview
ga('send', 'pageview');

if (!isBig) {
  ga('mobile.send', 'pageview');
}
</script>
<script>
// GA Page Load UK
if (isBig) {
  ga_pageLoad('UA-43334570-1', 'en', 'international', 'desktop');
} else {
  ga_pageLoad('UA-43334570-2', 'en', 'international', 'mobile web');
}
</script>
<script type="text/javascript">
    window._vis_opt_queue = window._vis_opt_queue || [], _vis_counter = 0;
    _vis_opt_queue.push(function() {
        try {
            if(!_vis_counter) {
                var _vis_data = "",_vis_combination,_vis_id,_vis_l=0;
                for(;_vis_l<_vwo_exp_ids.length;_vis_l++) {
                    _vis_id = _vwo_exp_ids[_vis_l];
                    if(_vwo_exp[_vis_id].ready) {
                        _vis_combination = _vis_opt_readCookie('_vis_opt_exp_'+_vis_id+'_combi');
                        if(typeof(_vwo_exp[_vis_id].combination_chosen) != "undefined")
                            _vis_combination = _vwo_exp[_vis_id].combination_chosen;
                        if(typeof(_vwo_exp[_vis_id].comb_n[_vis_combination]) != "undefined") {
                            _vis_data += 'VWOTestID-'+_vis_id + "=" + _vwo_exp[_vis_id].comb_n[_vis_combination] + "|";
                            _vis_counter++;
                        }
                    }
                }
                // Use the _vis_data object created above to fetch the data,
                // key of the object is the Test ID and the value is Variation Name
                if(_vis_counter) {
                    vwo_$(function() {
                        window.ga("set", "dimension25", _vis_data);
                        window.ga('send', 'event', 'VWO', 'Custom', {'nonInteraction': 1});
                    });
                }
            }
        }
        catch(err) {};
    });

</script>
<style>aside .widget{margin-bottom:1.5rem;}</style>
<meta name="apple-itunes-app" content="app-id=1084818519" />
</head>
<body id="entry" class="entry">

<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-P32JX6" height="0" width="0" style="display:none;visibility:hidden"></iframe</noscript>
<div class="layout" style="background-color:#FBFBFB">
<div class="layout__mobile_advert">
</div>

<header class="layout__header">
<nav id="services_navigation">
<ul class="services_nav">
<li class="services_nav__item">
<a href="https://betting.betfair.com">Betting.Betfair
</a></li>
<li class="services_nav__item">
<a href="https://betting.betfair.com/podcasts/">Podcasts
</a></li>
<li class="services_nav__item">
<a href="https://www.betfair.com/sport/">Betfair Sportsbook
</a></li>
<li class="services_nav__item">
<a href="https://betting.betfair.com/how-to-use-betfair-exchange/">Exchange How-to
</a></li>
<li class="services_nav__item">
<a href="https://www.betfair.com/exchange/plus/">Betfair Exchange
</a></li>
<li class="services_nav__item">
<a href="https://responsiblegambling.betfair.com/">Safer Gambling
</a></li>
<li class="services_nav__item" style="margin-left: auto;"><a href="https://register.betfair.com/account/registration?product=CIDF9QtQsFYf223X&amp;returnURL=https%3A%2F%2Fbetting.betfair.com%2Ffootball%2Fuefa-nations-league%2Fsaturday-nations-league-bet-builder-tips-germany-can-handle-italian-job-020622-629.html">Join</a></li>
<li class="services_nav__item"><a href="https://identitysso.betfair.com/view/login?product=CIDF9QtQsFYf223X&amp;url=https%3A%2F%2Fbetting.betfair.com%2Ffootball%2Fuefa-nations-league%2Fsaturday-nations-league-bet-builder-tips-germany-can-handle-italian-job-020622-629.html">Log in</a></li>
<li class="services_nav__item services_nav__item--toggle"><a class="full_nav_link" href="#full_navigation"><span>Menu</span></a></li>
</ul>
</nav> <div class="header">
<a class="header__logo" href="https://betting.betfair.com/">
<p style="position: static; top: 0; left: 0; margin: 0;"><img src="https://betting.betfair.com/images/bettingbetfairlogoblack.png" alt="Betting.Betfair" width="200" height="24"></p>
<p>Betting.Betfair</p>
</a>
<div class="header__nav">
<nav class="main_navigation">
<ul class="menu">
<li class="menu__item menu__item--active">
<span class="menu__toggle">More</span>
<a href="https://betting.betfair.com/football/">Football</a>
<nav class="sub_menu">
<div class="sub_menu__wrapper">
<div class="sub_menu__block sub_menu__block--featured">
<h4>Featured Football</h4>
<ul>
<li>
<a href="https://betting.betfair.com/football/uefa-nations-league/saturday-nations-league-bet-builder-tips-germany-can-handle-italian-job-020622-629.html">Saturday Nations League Bet Builder Tips: Germany can handle Italian job</a>
</li>
<li>
<a href="https://betting.betfair.com/football/football-tips/thursday-tips-betfair-cheat-sheet-all-the-best-bets-in-one-place-020622-204.html">Thursday Tips Cheat Sheet: All the best bets in one place</a>
</li>
<li>
<a href="https://betting.betfair.com/football/football-tips/the-jokers-bet-of-the-day/thursday-football-tips-back-sharp-shooters-to-shine-for-serbia-020622-1063.html">Thursday Football Tips: Back sharp shooters to shine for Serbia</a>
</li>
</ul>
</div>
<div class="sub_menu__block sub_menu__block--more">
<h4>More Football</h4>
<ul>
<li class="">
<a href="https://betting.betfair.com/football/football-tips/">Football Tips</a>
</li>
<li class="">
<a href="https://betting.betfair.com/football/premier-league/">Premier League</a>
</li>
<li class="">
<a href="https://betting.betfair.com/football/championship/">Championship</a>
</li>
<li class="">
<a href="https://betting.betfair.com/football/champions-league/">Champions League</a>
</li>
<li class="">
<a href="https://betting.betfair.com/football/fa-cup/">FA Cup</a>
</li>
<li class="">
<a href="https://betting.betfair.com/football/spanish-football/">Spanish Football</a>
</li>
<li class="">
<a href="https://betting.betfair.com/football/italian-football/">Italian Football</a>
</li>
<li class="">
<a href="https://betting.betfair.com/football/german-football/">German Football</a>
</li>
<li class="">
<a href="https://betting.betfair.com/football/french-football/">French Football</a>
</li>
<li class="">
<a href="https://betting.betfair.com/football/europa-league/">Europa League</a>
</li>
<li class="">
<a href="https://betting.betfair.com/football/world-cup-2022/">World Cup 2022</a>
</li>
</ul>
</div>
</div>
</nav>
</li>
<li class="menu__item">
<span class="menu__toggle">More</span>
<a href="https://betting.betfair.com/horse-racing/">Horse Racing</a>
<nav class="sub_menu">
<div class="sub_menu__wrapper">
<div class="sub_menu__block sub_menu__block--featured">
<h4>Featured Horse Racing</h4>
<ul>
<li>
<a href="https://betting.betfair.com/horse-racing/ryan-moore/ryan-moore-tuesday-has-each-way-claims-and-maybe-more-in-the-oaks-020622-368.html">Ryan Moore: Tuesday has each-way claims and maybe more in the Oaks</a>
</li>
<li>
<a href="https://betting.betfair.com/horse-racing/horseracing-tips/horse-racing-tips-rhys-williams-nap-is-a-hunter-chase-winner-at-uttoxeter-020622-1066.html">Horse Racing Tips: Rhys Williams' NAP is a hunter chase winner at Uttoxeter</a>
</li>
<li>
<a href="https://betting.betfair.com/horse-racing/kevin-blake-1/kevin-blakes-friday-racing-tips-back-concert-hall-to-produce-big-performance-in-open-oaks-020622-288.html">Kevin Blake's Friday Racing Tips: Back Concert Hall to produce big performance in open Oaks</a>
</li>
</ul>
</div>
<div class="sub_menu__block sub_menu__block--more">
<h4>More Horse Racing</h4>
<ul>
<li class="">
<a href="https://betting.betfair.com/horse-racing/horseracing-tips/">Horse Racing Tips</a>
</li>
<li class="">
<a href="https://betting.betfair.com/horse-racing/daily-racing-news/">Daily Racing News</a>
</li>
<li class="">
<a href="https://betting.betfair.com/horse-racing/horseracing-tips/itv-races/">ITV Races - Tony Calvin</a>
</li>
<li class="">
<a href="https://betting.betfair.com/horse-racing/kevin-blake-1/">Kevin Blake</a>
</li>
<li class="">
<a href="https://betting.betfair.com/horse-racing/royal-ascot/">Royal Ascot</a>
</li>
<li class="">
<a href="https://betting.betfair.com/horse-racing/paul-nicholls/">Paul Nicholls</a>
</li>
<li class="">
<a href="https://betting.betfair.com/horse-racing/bryony-frost/">Bryony Frost</a>
</li>
<li class="">
<a href="https://betting.betfair.com/horse-racing/horseracing-tips/bets-of-the-day/">Bets of the Day</a>
</li>
<li class="">
<a href="https://betting.betfair.com/horse-racing/horseracing-tips/daily-racing-multiple/">Daily Racing Multiple</a>
</li>
<li class="">
<a href="https://betting.betfair.com/horse-racing/ante-post/">Ante-Post</a>
</li>
</ul>
</div>
</div>
</nav>
</li>
<li class="menu__item">
<span class="menu__toggle">More</span>
<a href="https://betting.betfair.com/cricket/">Cricket</a>
<nav class="sub_menu">
<div class="sub_menu__wrapper">
<div class="sub_menu__block sub_menu__block--featured">
<h4>Featured Cricket</h4>
<ul>
<li>
<a href="https://betting.betfair.com/cricket/cricket-tips/england-v-new-zealand-first-test-top-bat-bowler-tips-raise-a-glass-to-jamieson-310522-194.html">Hawkeye on England v New Zealand First Test Tips: Raise a glass to Jamieson</a>
</li>
<li>
<a href="https://betting.betfair.com/cricket/cricket-tips/england-v-new-zealand-first-test-tips-unripe-kiwis-to-be-picked-off-310522-194.html">England v New Zealand First Test Tips: Unripe Kiwis to be picked off</a>
</li>
<li>
<a href="https://betting.betfair.com/cricket/indian-premier-league---ipl/gujarat-titans-v-rajasthan-royals-ipls-final-tips-the-players-to-follow-280522-194.html">Gujarat Titans v Rajasthan Royals IPL Final Tips: The players to follow</a>
</li>
</ul>
</div>
<div class="sub_menu__block sub_menu__block--more">
<h4>More Cricket</h4>
<ul>
<li class="">
<a href="https://betting.betfair.com/cricket/cricket-tips/">Cricket Tips</a>
</li>
<li class="">
<a href="https://betting.betfair.com/cricket/indian-premier-league---ipl/">Indian Premier League</a>
</li>
<li class="">
<a href="https://betting.betfair.com/cricket/pakistan-super-league/">Pakistan Super League</a>
</li>
<li class="">
<a href="https://betting.betfair.com/cricket/big-bash/">Big Bash</a>
</li>
<li class="">
<a href="https://betting.betfair.com/cricket/england-cricket/">England</a>
</li>
<li class="">
<a href="https://betting.betfair.com/cricket/australia-cricket/">Australia</a>
</li>
<li class="">
<a href="https://betting.betfair.com/cricket/india-cricket/">India</a>
</li>
<li class="">
<a href="https://betting.betfair.com/cricket/new-zealand-cricket/">New Zealand</a>
</li>
<li class="">
<a href="https://betting.betfair.com/cricket/south-africa-cricket/">South Africa</a>
</li>
<li class="">
<a href="https://betting.betfair.com/cricket/pakistan-cricket/">Pakistan</a>
</li>
<li class="">
<a href="https://betting.betfair.com/cricket/sri-lanka-cricket/">Sri Lanka</a>
</li>
</ul>
</div>
</div>
</nav>
</li>
<li class="menu__item">
<a href="https://betting.betfair.com/multiples/">Multiples Tips</a>
</li>
<li class="menu__item">
<span class="menu__toggle">More</span>
<a href="https://betting.betfair.com/tennis/">Tennis</a>
<nav class="sub_menu">
<div class="sub_menu__wrapper">
<div class="sub_menu__block sub_menu__block--featured">
<h4>Featured Tennis</h4>
<ul>
<li>
<a href="https://betting.betfair.com/tennis/french-open-betting/french-open-womens-semi-final-tips-trevisan-capable-of-continuing-shock-run-020622-778.html">French Open Women's Semi-Final Tips: Trevisan capable of continuing shock run</a>
</li>
<li>
<a href="https://betting.betfair.com/tennis/french-open-betting/french-open-mens-quarter-final-tips-market-with-little-faith-in-nadal-310522-778.html">French Open Men's Quarter-Final Tips: Market with little faith in Nadal</a>
</li>
<li>
<a href="https://betting.betfair.com/tennis/french-open-betting/french-open-womens-quarter-final-tips-Trevisan to continue incredible run-310522-778.html">French Open Women's Quarter-Final Tips: Trevisan to continue incredible run</a>
</li>
</ul>
</div>
<div class="sub_menu__block sub_menu__block--more">
<h4>More Tennis</h4>
<ul>
<li class="">
<a href="https://betting.betfair.com/tennis/australian-open-betting/">Australian Open</a>
</li>
<li class="">
<a href="https://betting.betfair.com/tennis/french-open-betting/">French Open</a>
</li>
<li class="">
<a href="https://betting.betfair.com/tennis/wimbledon/">Wimbledon</a>
</li>
<li class="">
<a href="https://betting.betfair.com/tennis/us-open/">US Open</a>
</li>
<li class="">
<a href="https://betting.betfair.com/tennis/events/">Events</a>
</li>
<li class="">
<a href="https://betting.betfair.com/tennis/atp-tour-finals-betting/">ATP Tour Finals</a>
</li>
<li class="">
<a href="https://betting.betfair.com/tennis/davis-cup-betting/">Davis Cup</a>
</li>
</ul>
</div>
</div>
</nav>
</li>
<li class="menu__item">
<span class="menu__toggle">More</span>
<a href="https://betting.betfair.com/golf/">Golf</a>
<nav class="sub_menu">
<div class="sub_menu__wrapper">
<div class="sub_menu__block sub_menu__block--featured">
<h4>Featured Golf</h4>
<ul>
<li>
<a href="https://betting.betfair.com/golf/golf-bets/golf-tips-best-bets-for-the-memorial-and-the-porsche-european-open-310522-6.html">Golf Tips: Best bets for the Memorial Tournament and the Porsche European Open</a>
</li>
<li>
<a href="https://betting.betfair.com/golf/golf-bets/find-me-a-100-winner/memorial-tournament-long-odds-golf-tips-look-to-lahiri-to-lap-up-the-lolly-010622-167.html">Find Me a 100 Winner: Look to Lahiri to lap up the lolly </a>
</li>
<li>
<a href="https://betting.betfair.com/golf/golf-bets/memorial-tournament-first-round-leader-tips-get-with-glover-010622-719.html">Memorial Tournament First-Round Leader Tips: Get with Glover</a>
</li>
</ul>
</div>
<div class="sub_menu__block sub_menu__block--more">
<h4>More Golf</h4>
<ul>
<li class="">
<a href="https://betting.betfair.com/golf/the-punter/">The Punter</a>
</li>
<li class="">
<a href="https://betting.betfair.com/golf/golf-bets/">Golf Bets</a>
</li>
<li class="">
<a href="https://betting.betfair.com/golf/european-tour/">DP World Tour</a>
</li>
<li class="">
<a href="https://betting.betfair.com/golf/pga-tour/">PGA Tour</a>
</li>
<li class="">
<a href="https://betting.betfair.com/golf/golf-form-guide/">Golf Form Guide</a>
</li>
<li class="">
<a href="https://betting.betfair.com/golf/us-masters/">US Masters</a>
</li>
<li class="">
<a href="https://betting.betfair.com/golf/the-open/">The Open</a>
</li>
<li class="">
<a href="https://betting.betfair.com/golf/us-open/">US Open</a>
</li>
<li class="">
<a href="https://betting.betfair.com/golf/us-pga-championship/">US PGA Championship</a>
</li>
<li class="">
<a href="https://betting.betfair.com/golf/ryder-cup/">Ryder Cup</a>
</li>
</ul>
</div>
</div>
</nav>
</li>
<li class="menu__item">
<span class="menu__toggle">More</span>
<a href="https://betting.betfair.com/politics/">Politics</a>
<nav class="sub_menu">
<div class="sub_menu__wrapper">
<div class="sub_menu__block sub_menu__block--featured">
<h4>Featured Politics</h4>
<ul>
<li>
<a href="https://betting.betfair.com/politics/uk-politics/boris-johnson-betting-prime-minister-odds-on-to-face-no-confidence-vote-in-june-010622-204.html">Boris Johnson Betting: Prime minister odds-on to face no confidence vote in June</a>
</li>
<li>
<a href="https://betting.betfair.com/politics/uk-politics/politics-live-the-latest-odds-moves-tips-and-analysis-on-betfairs-politics-markets-110122-171.html">Politics Live: Odds for 2022 Johnson exit falling fast as Tory revolt grows </a>
</li>
<li>
<a href="https://betting.betfair.com/politics/uk-politics/boris-johnson-to-leave-no10-bettors-back-2022-exit-for-pm-after-sue-gray-report-250522-204.html">Boris Johnson To Leave No.10: Bettors back 2022 exit for PM after Sue Gray report</a>
</li>
</ul>
</div>
<div class="sub_menu__block sub_menu__block--more">
<h4>More Politics</h4>
<ul>
<li class="">
<a href="https://betting.betfair.com/politics/us-politics/">US Politics</a>
</li>
<li class="">
<a href="https://betting.betfair.com/politics/brexit/">Brexit</a>
</li>
<li class="">
<a href="https://betting.betfair.com/politics/uk-politics/">UK Politics</a>
</li>
<li class="">
<a href="https://betting.betfair.com/politics/general-election/">General Election </a>
</li>
<li class="">
<a href="https://betting.betfair.com/politics/general-politics-betting/">General Politics Betting</a>
</li>
<li class="">
<a href="https://betting.betfair.com/politics/french-politics/">French Politics</a>
</li>
</ul>
</div>
</div>
</nav>
</li>
<li class="menu__item">
<span class="menu__toggle">More</span>
<a href="https://betting.betfair.com/specials/">Specials</a>
<nav class="sub_menu">
<div class="sub_menu__wrapper">
<div class="sub_menu__block sub_menu__block--featured">
<h4>Featured Specials</h4>
<ul>
<li>
<a href="https://betting.betfair.com/specials/eurovision-song-contest/eurovision-song-contest-2022-tips-back-poland-for-a-top-4-finish-220422-1130.html">Eurovision Song Contest 2022 Tips: Back Sweden for the win</a>
</li>
<li>
<a href="https://betting.betfair.com/specials/eurovision-song-contest/eurovision-semi-final-2-tips-oppose-cyprus-to-qualify-210422-1130.html">Eurovision Semi-Final 2 Tips: Get against Cyprus in qualification betting</a>
</li>
<li>
<a href="https://betting.betfair.com/specials/eurovision-song-contest/eurovision-song-contest-2022-tips-back-greece-to-win-semi-final-one-200422-1130.html">Eurovision Semi-Final 1 Tips: Back Greece for the win</a>
</li>
</ul>
</div>
<div class="sub_menu__block sub_menu__block--more">
<h4>More Specials</h4>
<ul>
<li class="">
<a href="https://betting.betfair.com/specials/spoty/">Sports Personality of the Year</a>
</li>
<li class="">
<a href="https://betting.betfair.com/specials/eurovision-song-contest/">Eurovision Song Contest</a>
</li>
<li class="">
<a href="https://betting.betfair.com/specials/oscars/">Oscars</a>
</li>
<li class="">
<a href="https://betting.betfair.com/specials/strictly-come-dancing/">Strictly Come Dancing</a>
</li>
<li class="">
<a href="https://betting.betfair.com/specials/im-a-celebrity/">I'm a Celebrity</a>
</li>
</ul>
</div>
</div>
</nav>
</li>
<li class="menu__item">
<span class="menu__toggle">More</span>
<a href="https://betting.betfair.com/rugby/">Rugby</a>
<nav class="sub_menu">
<div class="sub_menu__wrapper">
<div class="sub_menu__block sub_menu__block--featured">
<h4>Featured Rugby</h4>
<ul>
<li>
<a href="https://betting.betfair.com/rugby/rugby-union/six-nations-cheat-sheet-best-bets-for-wales-v-france-england-v-ireland-and-italy-v-scotland-010322-624.html">Six Nations Cheat Sheet: Best bets for Wales v France, England v Ireland and Italy v Scotland</a>
</li>
<li>
<a href="https://betting.betfair.com/rugby/rugby-union/six-nations-betting-france-odds-on-for-grand-slam-but-wales-and-england-await-030322-204.html">Six Nations Betting: France odds-on for Grand Slam but Wales and England await</a>
</li>
<li>
<a href="https://betting.betfair.com/rugby/rugby-union/six-nations-betting/six-nations-cheat-sheet-best-bets-for-england-v-wales-scotland-v-france-and-ireland-v-italy-180222-624.html">Six Nations Cheat Sheet: Best bets for England v Wales, Scotland v France and Ireland v Italy</a>
</li>
</ul>
</div>
<div class="sub_menu__block sub_menu__block--more">
<h4>More Rugby</h4>
<ul>
<li class="">
<a href="https://betting.betfair.com/rugby/rugby-world-cup/">Rugby World Cup</a>
</li>
<li class="">
<a href="https://betting.betfair.com/rugby/rugby-union/six-nations-betting/">Six Nations</a>
</li>
<li class="">
<a href="https://betting.betfair.com/rugby/rugby-league/super-league/">Super League</a>
</li>
<li class="">
<a href="https://betting.betfair.com/rugby/aviva-premiership/">Aviva Premiership</a>
</li>
<li class="">
<a href="https://betting.betfair.com/rugby/european-champions-cup/">European Champions Cup</a>
</li>
<li class="">
<a href="https://betting.betfair.com/rugby/rugby-league/">Rugby League</a>
</li>
<li class="">
<a href="https://betting.betfair.com/rugby/rugby-union/">Rugby Union</a>
</li>
</ul>
</div>
</div>
</nav>
</li>
<li class="menu__item">
<a href="https://betting.betfair.com/betting/formula-one/">Formula 1</a>
</li>
<li class="menu__item">
<span class="menu__toggle">More</span>
<a href="https://betting.betfair.com/betting/">Other Sports</a>
<nav class="sub_menu">
<div class="sub_menu__wrapper">
<div class="sub_menu__block sub_menu__block--featured">
<h4>Featured Other Sports</h4>
<ul>
<li>
<a href="https://betting.betfair.com/betting/boxing/kenichi-ogawa-v-joe-cordina-tips-welshman-to-delight-the-home-crowd-in-cardiff-020622-746.html">Kenichi Ogawa v Joe Cordina: Welshman to delight the home crowd in Cardiff</a>
</li>
<li>
<a href="https://betting.betfair.com/betting/boxing/devin-haney-v-george-kambosos-jr-tips-the-dreams-run-of-points-wins-will-continue-020622-746.html">Devin Haney v George Kambosos Jr: The Dream's run of points wins will continue Down Under</a>
</li>
<li>
<a href="https://betting.betfair.com/betting/other/giro-ditalia-stage-21-tips-tulett-on-ineos-rescue-mission-280522-186.html">Giro d'Italia Stage 21 Tips: Tulett on Ineos rescue mission</a>
</li>
</ul>
</div>
<div class="sub_menu__block sub_menu__block--more">
<h4>More Other Sports</h4>
<ul>
<li class="">
<a href="https://betting.betfair.com/betting/athletics/">Athletics</a>
</li>
<li class="">
<a href="https://betting.betfair.com/betting/gaa-1/">GAA</a>
</li>
<li class="">
<a href="https://betting.betfair.com/betting/boxing/">Boxing</a>
</li>
<li class="">
<a href="https://betting.betfair.com/betting/darts/">Darts</a>
</li>
 <li class="">
<a href="https://betting.betfair.com/betting/esports/">eSports</a>
</li>
<li class="">
<a href="https://betting.betfair.com/betting/ufc/">UFC</a>
</li>
</ul>
</div>
</div>
</nav>
</li>
</ul>
</nav>
</div>
</div> <nav id="features_navigation">
<ul class="features_navigation">
<li class="features_navigation__item">
<a class="features_navigation__card" href="https://betting.betfair.com/football/premier-league/">Premier League Tips</a>
</li>
<li class="features_navigation__item">
<a class="features_navigation__card" href="https://betting.betfair.com/football/champions-league/">Champions League Tips</a>
</li>
<li class="features_navigation__item">
<a class="features_navigation__card" href="https://betting.betfair.com/football/championship/">Championship Tips</a>
</li>
<li class="features_navigation__item">
<a class="features_navigation__card" href="https://betting.betfair.com/football/football-tips/">Daily Football Tips</a>
</li>
<li class="features_navigation__item">
<a class="features_navigation__card" href="https://betting.betfair.com/football/premier-league/premier-league-manager-markets-the-latest-news-and-betting-011121-6.html">Manager Markets Blog</a>
</li>
<li class="features_navigation__item">
<a class="features_navigation__card" href="https://betting.betfair.com/football/football-tips/daily-acca/">The Daily Acca</a>
</li>
</ul>
</nav>
</header>
<div class="takeover_adverts">
<div class="takeover_adverts__main">
</div>
<div class="takeover_adverts__left">
</div>
<div class="takeover_adverts__right">
</div>
</div>

<main class="layout__main layout__main--padding">
<div class="features_nav_carousel">
<div class="features_nav_carousel__item">
<a class="features_nav_carousel__card" href="https://betting.betfair.com/football/premier-league/" style="background-image: url('//betting.cdnppb.net/Virgil VD and Mo Salah 1280.220x124.jpg');">
<div><h4>Premier League Tips</h4></div>
</a>
</div>
<div class="features_nav_carousel__item">
<a class="features_nav_carousel__card" href="https://betting.betfair.com/football/champions-league/" style="background-image: url('//betting.cdnppb.net/Robert Lewandowski celebrates 1280.220x124.jpg');">
<div><h4>Champions League Tips</h4></div>
</a>
</div>
<div class="features_nav_carousel__item">
<a class="features_nav_carousel__card" href="https://betting.betfair.com/football/championship/" style="background-image: url('//betting.cdnppb.net/Floodlights.220x147.jpg');">
<div><h4>Championship Tips</h4></div>
</a>
</div>
<div class="features_nav_carousel__item">
<a class="features_nav_carousel__card" href="https://betting.betfair.com/football/football-tips/" style="background-image: url('//betting.cdnppb.net/Player kicking ball - 1280.220x124.jpg');">
<div><h4>Daily Football Tips</h4></div>
</a>
</div>
<div class="features_nav_carousel__item">
<a class="features_nav_carousel__card" href="https://betting.betfair.com/football/premier-league/premier-league-manager-markets-the-latest-news-and-betting-011121-6.html" style="background-image: url('//betting.cdnppb.net/Mauricio Pochettino moody 1280.220x124.jpg');">
<div><h4>Manager Markets Blog</h4></div>
</a>
</div>
<div class="features_nav_carousel__item">
<a class="features_nav_carousel__card" href="https://betting.betfair.com/football/football-tips/daily-acca/" style="background-image: url('//betting.cdnppb.net/Ball in the net.220x146.jpg');">
<div><h4>The Daily Acca</h4></div>
</a>
</div>
</div>

<header class="entry_header">
<h1 class="entry_header__title">Saturday Nations League Bet Builder Tips: Germany can handle Italian job</h1>
<ul class="entry_header__meta">
<li><a href="https://betting.betfair.com/authors/dan-fitch/">Dan Fitch</a></li>
<li><time datetime="2022-06-02">02 June 2022</time></li>
<li>3:00 min read</li>
</ul>
<script type="application/ld+json">
  {
    "@context": "http://schema.org",
    "@type": "Article",
    "headline": "Saturday Nations League Bet Builder Tips: Germany can handle Italian job",
    "name": "Saturday Nations League Bet Builder Tips: Germany can handle Italian job",
    "description": "Germany are in fine form under new management and Dan Fitch thinks they will get a positive result against struggling Italy, as he picks Bet Builders for Sat...",
    "url": "https://betting.betfair.com/football/uefa-nations-league/saturday-nations-league-bet-builder-tips-germany-can-handle-italian-job-020622-629.html",
    "mainEntityOfPage": "https://betting.betfair.com/football/uefa-nations-league/saturday-nations-league-bet-builder-tips-germany-can-handle-italian-job-020622-629.html",
    "datePublished": "2022-06-02T15:18:00+01:00",
        "dateModified": "2022-06-02T15:57:00+01:00",
            "thumbnailURL": "https://betting.cdnppb.net/football/Flick150321.320x180.jpg",
        "articleBody": "Germany are in fine form under new management and Dan Fitch thinks they will get a positive result against struggling Italy, as he picks Bet Builders for Saturday&#039;s Nations League ties.  Finland had the edge in recent encounters  Finland [2.68] v Bosnia [2.84]; The Draw [3.2]Saturday 4 July, 17:00Live on Premier Sports 1 Home advantage makes Finland the narrow favourites in this one, with neither side in good form. The hosts are without a win in three games (D1 L2), while Bosnia&#039;s victory against Luxembourg in their last outing, ended a run of four successive defeats. These sides met in the latest World Cup qualifiers, with Finland drawing 2-2 in the home fixture and winning 3-1 away. You can combine Finland double chance and both teams to score in a Bet Builder and get odds of [2.4]. Nations League has helped Luxembourg grow  Lithuania [3.45] v Luxembourg [2.38]; The Draw [3.0]Saturday 4 July, 17:00Live on Premier Player It says much for Luxembourg&#039;s progress that they are favourites for this match. Their improvement has been in large part due to the format of the Nations League, which has given them regular winnable fixtures. Lithuania have kept it pretty tight of late, with only one of their last four games seeing three goals or more. Back Luxembourg double chance and under 2.5 goals at [1.8]. Germany can take advantage of Italy woe  Italy [2.84] v Germany [2.72]; The Draw [3.5]Saturday 4 July, 19:45Live on Premier Sports 1 It&#039;s hard to think of many changes of fortunes, as swift as Italy have suffered. As recently as last October, they were freshly crowned European champions, were through to the semi-finals of last season&#039;s Nations League and seemingly cruising through World Cup qualification. Since then, they&#039;ve suffered defeat in the Nations League semis, finished second in their World Cup qualifying group, got knocked out of the play-offs by North Macedonia and in midweek were beaten 3-0 by the South American champions Argentina in Finalissima. In contrast, Germany are unbeaten in nine under new manager Hansi Flick (W8 D1), since losing to England at Euro 2020. With Italy failing to score in three of their last four games, backing Germany double chance and under 3.5 goals, makes sense at [1.87]. Back score draw  Montenegro [3.25] v Romania [2.48]; The Draw [3.1]Saturday 4 July, 19:45Live on BoxNation Romania are rightful favourites here, but Montenegro shouldn&#039;t be dismissed. The visitors have only lost two of their last nine games (W4 D3), but one of those losses was at home to Greece. Montenegro beat Greece in their last outing and are capable of pulling off a surprise result, as they proved in November when they drew with Netherlands. Take a chance on the draw and both teams to score at [4.2]. Turkey will get off to flyer against Faroes  Turkey [1.14] v Faroe Islands [27.0]; The Draw [9.8]Saturday 4 July, 19:45Live on Premier Player Turkey find themselves in Group C1 of the Nations League, against the Faroes, Luxembourg and Lithuania. They should make a swift return to the second-tier and it would be a major surprise if they didn&#039;t start their campaign with a solid win. The Faroes regularly pull off positive results, but when they step up to a team of Turkey&#039;s level, they&#039;re generally defeated. Back Turkey half-time/full-time and over 2.5 goals at [1.88]. ",
            "image": {
      "@type": "ImageObject",
      "url": "https://betting.cdnppb.net/football/Flick150321.jpg",
        "height": 538,
        "width": 956
          },
        "publisher": {
      "@type": "Organization",
      "name": "Betting.Betfair",
      "logo": {
        "@type": "ImageObject",
        "url": "https://betting.cdnppb.net/_v2/img/betfairlogoblack.png"
      },
      "url": "https://betting.betfair.com/"
    },
    "author": "Dan Fitch"
  }
</script>
</header>
<div class="two_column_layout">
<main class="entry_main">
<div class="entry_img">
<img src="//betting.cdnppb.net/football/Flick150321.728x410.jpg" srcset="//betting.cdnppb.net/football/Flick150321.450x253.jpg 450w, 
                       //betting.cdnppb.net/football/Flick150321.600x338.jpg 600w, 
                       //betting.cdnppb.net/football/Flick150321.728x410.jpg 728w" alt="Hansi Flick.">
<figcaption class="entry_img__caption">Will Hansi Flick inspire Germany when they travel to face Italy?</figcaption>
</div>


<div class="entry_actions">
<div>
<a class="button button--dark" href="https://promotions.betfair.com/prs/exchange-acq-uk-bau-money-back20-newvi-generic?rfr=2573">Join</a>
</div>
<div>
<a class="button btn--market" data-market_full="https://www.betfair.com/sport/football/uefa-nations-league/italy-v-germany/31280487" data-contextual_info='{"blog_name":"Football UK","category_label":"UEFA Nations League","market_id":"https:\/\/www.betfair.com\/sport\/football\/uefa-nations-league\/italy-v-germany\/31280487","entry_title":"Saturday Nations League Bet Builder Tips: Germany can handle Italian job"}' href="https://www.betfair.com/sport/football/uefa-nations-league/italy-v-germany/31280487">View market</a>
</div>
<div class="entry_actions__social entry_actions__social--twitter">
<a href="https://twitter.com/intent/tweet/?text=Saturday%20Nations%20League%20Bet%20Builder%20Tips%3A%20Germany%20can%20handle%20Italian%20job&url=https%3A%2F%2Fbetting.betfair.com%2Ffootball%2Fuefa-nations-league%2Fsaturday-nations-league-bet-builder-tips-germany-can-handle-italian-job-020622-629.html" target="_blank" title="Twitter"><span class="sprite_icon sprite_icon--twitter">Twitter</span></a>
</div>
<div class="entry_actions__social entry_actions__social--facebook">
<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fbetting.betfair.com%2Ffootball%2Fuefa-nations-league%2Fsaturday-nations-league-bet-builder-tips-germany-can-handle-italian-job-020622-629.html" target="_blank" title="Facebook"><span class="sprite_icon sprite_icon--facebook">Facebook</span></a>
</div>
<div class="entry_actions__social entry_actions__social--reddit">
<a href="https://www.reddit.com/submit/?url=https%3A%2F%2Fbetting.betfair.com%2Ffootball%2Fuefa-nations-league%2Fsaturday-nations-league-bet-builder-tips-germany-can-handle-italian-job-020622-629.html" target="_blank" title="Reddit"><span class="sprite_icon sprite_icon--reddit">Reddit</span></a>
</div>
<div class="entry_actions__social entry_actions__social--whatsapp">
<a href="https://api.whatsapp.com/send?text=https%3A%2F%2Fbetting.betfair.com%2Ffootball%2Fuefa-nations-league%2Fsaturday-nations-league-bet-builder-tips-germany-can-handle-italian-job-020622-629.html" target="_blank" title="WhatsApp"><span class="sprite_icon sprite_icon--whatsapp">WhatsApp</span></a>
</div>
<div class="entry_actions__social entry_actions__social--telegram">
<a href="https://t.me/share/url?url=https%3A%2F%2Fbetting.betfair.com%2Ffootball%2Fuefa-nations-league%2Fsaturday-nations-league-bet-builder-tips-germany-can-handle-italian-job-020622-629.html&text=Saturday%20Nations%20League%20Bet%20Builder%20Tips%3A%20Germany%20can%20handle%20Italian%20job" target="_blank" title="Telegram"><span class="sprite_icon sprite_icon--telegram">Telegram</span></a>
</div>
</div>
<div class="entry_body has-odds">

<p class="entry_body__intro">Germany are in fine form under new management and Dan Fitch thinks they will get a positive result against struggling Italy, as he picks Bet Builders for Saturday&#039;s Nations League ties.</p>

<div class="entry_body__quote">
<blockquote>"Germany are unbeaten in nine under new manager Hansi Flick (W8 D1), since losing to England at Euro 2020."
<br></br>
<a href="https://www.betfair.com/sport/football/uefa-nations-league/italy-v-germany/31280487">Back Germany double chance against Italy and under 3.5 goals at <b class="inline_odds" title="5/6"><span class="inline_odds__decimal">1.87</span><span class="inline_odds__fractional inline_odds__tooltip">5/6</span></b></a></blockquote>
</div>

<div class="entry_body__content">
<div class="editor">
<h2><h2>Finland had the edge in recent encounters</h2><p></p><p><a href="https://www.betfair.com/exchange/plus/football/market/1.199240842">Finland <b class="inline_odds" title="13/8"><span class="inline_odds__decimal">2.68</span><span class="inline_odds__fractional inline_odds__tooltip">13/8</span></b> v Bosnia <b class="inline_odds" title="15/8"><span class="inline_odds__decimal">2.84</span><span class="inline_odds__fractional inline_odds__tooltip">15/8</span></b>; The Draw <b class="inline_odds" title="11/5"><span class="inline_odds__decimal">3.2</span><span class="inline_odds__fractional inline_odds__tooltip">11/5</span></b></a><br><strong>Saturday 4 July, 17:00</strong><br><strong>Live on Premier Sports 1</strong></p><p>Home advantage makes Finland the narrow favourites in this one, with neither side in good form. The hosts are without a win in three games (D1 L2), while Bosnia's victory against Luxembourg in their last outing, ended a run of four successive defeats.</p><p>These sides met in the latest World Cup qualifiers, with Finland drawing 2-2 in the home fixture and winning 3-1 away. You can combine <a href="https://www.betfair.com/sport/football/uefa-nations-league/finland-v-bosnia/31460731">Finland double chance and both teams to score</a> in a Bet Builder and get odds of <b class="inline_odds" title="7/5"><span class="inline_odds__decimal">2.4</span><span class="inline_odds__fractional inline_odds__tooltip">7/5</span></b>.</p><h2>Nations League has helped Luxembourg grow</h2><p></p><p><a href="https://www.betfair.com/exchange/plus/football/market/1.199241330">Lithuania 3.45 v Luxembourg <b class="inline_odds" title="11/8"><span class="inline_odds__decimal">2.38</span><span class="inline_odds__fractional inline_odds__tooltip">11/8</span></b>; The Draw <b class="inline_odds" title="2/1"><span class="inline_odds__decimal">3.0</span><span class="inline_odds__fractional inline_odds__tooltip">2/1</span></b></a><br><strong>Saturday 4 July, 17:00</strong><br><strong>Live on Premier Player</strong></p><p>It says much for Luxembourg's progress that they are favourites for this match. Their improvement has been in large part due to the format of the Nations League, which has given them regular winnable fixtures.</p><p>Lithuania have kept it pretty tight of late, with only one of their last four games seeing three goals or more. Back <a href="https://www.betfair.com/sport/football/uefa-nations-league/lithuania-v-luxembourg/31460730">Luxembourg double chance and under 2.5 goals</a> at <b class="inline_odds" title="4/5"><span class="inline_odds__decimal">1.8</span><span class="inline_odds__fractional inline_odds__tooltip">4/5</span></b>.</p><h2>Germany can take advantage of Italy woe</h2><p></p><p><a href="https://www.betfair.com/exchange/plus/football/market/1.195631361">Italy <b class="inline_odds" title="15/8"><span class="inline_odds__decimal">2.84</span><span class="inline_odds__fractional inline_odds__tooltip">15/8</span></b> v Germany <b class="inline_odds" title="7/4"><span class="inline_odds__decimal">2.72</span><span class="inline_odds__fractional inline_odds__tooltip">7/4</span></b>; The Draw <b class="inline_odds" title="5/2"><span class="inline_odds__decimal">3.5</span><span class="inline_odds__fractional inline_odds__tooltip">5/2</span></b></a><br><strong>Saturday 4 July, 19:45</strong><br><strong>Live on Premier Sports 1</strong></p><p>It's hard to think of many changes of fortunes, as swift as Italy have suffered. As recently as last October, they were freshly crowned European champions, were through to the semi-finals of last season's Nations League and seemingly cruising through World Cup qualification. Since then, they've suffered defeat in the Nations League semis, finished second in their World Cup qualifying group, got knocked out of the play-offs by North Macedonia and in midweek were beaten 3-0 by the South American champions Argentina in Finalissima.</p><p>In contrast, Germany are unbeaten in nine under new manager Hansi Flick (W8 D1), since losing to England at Euro 2020. With Italy failing to score in three of their last four games, backing <a href="https://www.betfair.com/sport/football/uefa-nations-league/italy-v-germany/31280487">Germany double chance and under 3.5 goals</a>, makes sense at <b class="inline_odds" title="5/6"><span class="inline_odds__decimal">1.87</span><span class="inline_odds__fractional inline_odds__tooltip">5/6</span></b>.</p><h2>Back score draw</h2><p></p><p><a href="https://www.betfair.com/exchange/plus/football/market/1.192640684">Montenegro <b class="inline_odds" title="9/4"><span class="inline_odds__decimal">3.25</span><span class="inline_odds__fractional inline_odds__tooltip">9/4</span></b> v Romania <b class="inline_odds" title="6/4"><span class="inline_odds__decimal">2.48</span><span class="inline_odds__fractional inline_odds__tooltip">6/4</span></b>; The Draw <b class="inline_odds" title="85/40"><span class="inline_odds__decimal">3.1</span><span class="inline_odds__fractional inline_odds__tooltip">85/40</span></b></a><br><strong>Saturday 4 July, 19:45</strong><br><strong>Live on BoxNation</strong></p><p>Romania are rightful favourites here, but Montenegro shouldn't be dismissed. The visitors have only lost two of their last nine games (W4 D3), but one of those losses was at home to Greece.</p><p>Montenegro beat Greece in their last outing and are capable of pulling off a surprise result, as they proved in November when they drew with Netherlands. Take a chance on <a href="https://www.betfair.com/sport/football/uefa-nations-league/montenegro-v-romania/31141491">the draw and both teams to score</a> at <b class="inline_odds" title="16/5"><span class="inline_odds__decimal">4.2</span><span class="inline_odds__fractional inline_odds__tooltip">16/5</span></b>.</p><h2>Turkey will get off to flyer against Faroes</h2><p></p><p><a href="https://www.betfair.com/exchange/plus/football/market/1.199241086">Turkey <b class="inline_odds" title="1/7"><span class="inline_odds__decimal">1.14</span><span class="inline_odds__fractional inline_odds__tooltip">1/7</span></b> v Faroe Islands <b class="inline_odds" title="26/1"><span class="inline_odds__decimal">27.0</span><span class="inline_odds__fractional inline_odds__tooltip">26/1</span></b>; The Draw <b class="inline_odds" title="9/1"><span class="inline_odds__decimal">9.8</span><span class="inline_odds__fractional inline_odds__tooltip">9/1</span></b></a><br><strong>Saturday 4 July, 19:45</strong><br><strong>Live on Premier Player</strong></p><p>Turkey find themselves in Group C1 of the Nations League, against the Faroes, Luxembourg and Lithuania. They should make a swift return to the second-tier and it would be a major surprise if they didn't start their campaign with a solid win.</p><p>The Faroes regularly pull off positive results, but when they step up to a team of Turkey's level, they're generally defeated. Back <a href="https://www.betfair.com/sport/football/uefa-nations-league/turkey-v-faroe-islands/31460740">Turkey half-time/full-time and over 2.5 goals</a> at <b class="inline_odds" title="10/11"><span class="inline_odds__decimal">1.88</span><span class="inline_odds__fractional inline_odds__tooltip">10/11</span></b>.</p><p></p></h2>
</div>
</div>

<section class="betting_copy">
<div class="editor">
<h2>Get Enhanced Prices on Accas</h2>
<p>Get enhanced prices on Acca bets throughout the day no matter what football you're betting on. This offer applies to Betfair Boost selections, to help increase your returns across all enhanced Accas. Maximum stake varies and <a href="https://promos.betfair.com/sport" target="_blank">T&Cs apply</a>.</p>
</div>
</section>



<div class="recommended_bets betslip_goto auto_banners" data-banner_cta="Join">
<h3>Recommended bets</h3>
<div class="editor editor--reversed">
<p><a href="https://www.betfair.com/sport/football/uefa-nations-league/finland-v-bosnia/31460731">Back Finland double chance against Bosnia and both teams to score at <b class="inline_odds" title="7/5"><span class="inline_odds__decimal">2.4</span><span class="inline_odds__fractional inline_odds__tooltip">7/5</span></b></a><br><a href="https://www.betfair.com/sport/football/uefa-nations-league/lithuania-v-luxembourg/31460730">Back Luxembourg double chance against Lithuania and under 2.5 goals at <b class="inline_odds" title="4/5"><span class="inline_odds__decimal">1.8</span><span class="inline_odds__fractional inline_odds__tooltip">4/5</span></b></a><br><a href="https://www.betfair.com/sport/football/uefa-nations-league/italy-v-germany/31280487">Back Germany double chance against Italy and under 3.5 goals at <b class="inline_odds" title="5/6"><span class="inline_odds__decimal">1.87</span><span class="inline_odds__fractional inline_odds__tooltip">5/6</span></b></a><br><a href="https://www.betfair.com/sport/football/uefa-nations-league/montenegro-v-romania/31141491">Back Montenegro and Romania to draw and both teams to score at <b class="inline_odds" title="16/5"><span class="inline_odds__decimal">4.2</span><span class="inline_odds__fractional inline_odds__tooltip">16/5</span></b></a><br><a href="https://www.betfair.com/sport/football/uefa-nations-league/turkey-v-faroe-islands/31460740">Back Turkey half-time/full-time against Faroe Islands and over 2.5 goals at <b class="inline_odds" title="10/11"><span class="inline_odds__decimal">1.88</span><span class="inline_odds__fractional inline_odds__tooltip">10/11</span></b></a></p>
</div>
</div>
<div id="betslip" class="entry_body__extras">
</div>
<div class="entry_body__widgets">
<div class="widget-context widget-context--both">
<div class="widget" data-context="both">
<div id="betnow-uk-widget" class="widget__body">
<h3><span style="color: white;">Get a Free £/€20</span> Exchange Bet</h3>
<ul>
<li><strong>Join Now</strong> - Open account using promo code <strong>VAL225</strong></li>
<li><strong>Bet</strong> - Place a £/€20 Bet on the Exchange</li>
<li><strong>Earn</strong> We'll Refund You £/€20 If the Bet Loses</li>
</ul>
<p><small>T&amp;Cs apply.</small></p>
</div>
<div class="widget__footer" style="margin-bottom: 1.5rem;"><a class="btn btn--market" href="https://promotions.betfair.com/prs/exchange-acq-uk-bau-free20-val225-temp" target="_blank">Bet now</a></div>
</div>
</div>
</div>

<div class="entry_actions">
<div>
<a class="button button--dark" href="https://promotions.betfair.com/prs/exchange-acq-uk-bau-money-back20-newvi-generic?rfr=2573">Join</a>
</div>
<div>
<a class="button btn--market" data-market_full="https://www.betfair.com/sport/football/uefa-nations-league/italy-v-germany/31280487" data-contextual_info='{"blog_name":"Football UK","category_label":"UEFA Nations League","market_id":"https:\/\/www.betfair.com\/sport\/football\/uefa-nations-league\/italy-v-germany\/31280487","entry_title":"Saturday Nations League Bet Builder Tips: Germany can handle Italian job"}' href="https://www.betfair.com/sport/football/uefa-nations-league/italy-v-germany/31280487">View market</a>
</div> </div>

<div class="entry_share">
<ul class="button_group">
<li class="button_group__twitter">
<a href="https://twitter.com/intent/tweet/?text=Saturday%20Nations%20League%20Bet%20Builder%20Tips%3A%20Germany%20can%20handle%20Italian%20job&url=https%3A%2F%2Fbetting.betfair.com%2Ffootball%2Fuefa-nations-league%2Fsaturday-nations-league-bet-builder-tips-germany-can-handle-italian-job-020622-629.html" target="_blank" title="Twitter"><span class="sprite_icon sprite_icon--twitter">Twitter</span></a>
</li>
<li class="button_group__facebook">
<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fbetting.betfair.com%2Ffootball%2Fuefa-nations-league%2Fsaturday-nations-league-bet-builder-tips-germany-can-handle-italian-job-020622-629.html" target="_blank" title="Facebook"><span class="sprite_icon sprite_icon--facebook">Facebook</span></a>
</li>
<li class="button_group__reddit">
<a href="https://www.reddit.com/submit/?url=https%3A%2F%2Fbetting.betfair.com%2Ffootball%2Fuefa-nations-league%2Fsaturday-nations-league-bet-builder-tips-germany-can-handle-italian-job-020622-629.html" target="_blank" title="Reddit"><span class="sprite_icon sprite_icon--reddit">Reddit</span></a>
</li>
<li class="button_group__whatsapp">
<a href="https://api.whatsapp.com/send?text=https%3A%2F%2Fbetting.betfair.com%2Ffootball%2Fuefa-nations-league%2Fsaturday-nations-league-bet-builder-tips-germany-can-handle-italian-job-020622-629.html" target="_blank" title="WhatsApp"><span class="sprite_icon sprite_icon--whatsapp">WhatsApp</span></a>
</li>
<li class="button_group__telegram">
<a href="https://t.me/share/url?url=https%3A%2F%2Fbetting.betfair.com%2Ffootball%2Fuefa-nations-league%2Fsaturday-nations-league-bet-builder-tips-germany-can-handle-italian-job-020622-629.html&text=Saturday%20Nations%20League%20Bet%20Builder%20Tips%3A%20Germany%20can%20handle%20Italian%20job" target="_blank" title="Telegram"><span class="sprite_icon sprite_icon--telegram">Telegram</span></a>
</li>
</ul>
</div>

<div class="fb-comments" data-href="https://betting.betfair.com/football/uefa-nations-league/saturday-nations-league-bet-builder-tips-germany-can-handle-italian-job-020622-629.html" data-width="100%" data-numposts="10"></div>

<h3 class="section_title">Discover the latest articles</h3>
<ul class="related_entries">
<li>
<article>
<a href="https://betting.betfair.com/football/football-tips/thursday-tips-betfair-cheat-sheet-all-the-best-bets-in-one-place-020622-204.html">Thursday Tips Cheat Sheet: All the best bets in one place</a>
<img src="//betting.cdnppb.net/football/ronaldo_euro_2020.728x410.jpg" alt="https://betting.betfair.com/football/ronaldo_euro_2020.jpg" loading="lazy">
</article>
</li>
<li>
<article>
<a href="https://betting.betfair.com/football/football-tips/the-jokers-bet-of-the-day/thursday-football-tips-back-sharp-shooters-to-shine-for-serbia-020622-1063.html">Thursday Football Tips: Back sharp shooters to shine for Serbia</a>
<img src="//betting.cdnppb.net/football/1280 Aleksandar Mitrovic Serbia.728x410.jpg" alt="https://betting.betfair.com/football/1280%20Aleksandar%20Mitrovic%20Serbia.jpg" loading="lazy">
</article>
</li>
<li>
<article>
<a href="https://betting.betfair.com/football/uefa-nations-league/friday-nations-league-bet-builder-tips-mbappe-can-keep-firing-for-france-010622-629.html">Friday Nations League Bet Builder Tips: Mbappe can keep firing for France</a>
<img src="//betting.cdnppb.net/football/b313c1be4c9f22193db040201e828ad816cc685d.728x485.jpg" alt="https://betting.betfair.com/football/b313c1be4c9f22193db040201e828ad816cc685d.jpg" loading="lazy">
</article>
</li>
</ul>
<h3 class="section_title">Read past articles</h3>
<ul class="related_entries">
<li>
<article>
<a href="https://betting.betfair.com/football/football-tips/daily-acca/the-daily-acca-a-101-boost-from-the-nations-league-020622-35.html">The Daily Acca: A 10/1 boost from the Nations League</a>
<img src="//betting.cdnppb.net/football/Enrique smiling 1280.728x410.jpg" alt="https://betting.betfair.com/football/Enrique%20smiling%201280.jpg" loading="lazy">
</article>
</li>
<li>
<article>
<a href="https://betting.betfair.com/football/football-tips/daily-acca/the-daily-acca-a-boosted-treble-from-norway-310522-35.html">The Daily Acca: A boosted treble from Norway</a>
<img src="//betting.cdnppb.net/football/Norway fans flags 1280.728x410.jpg" alt="https://betting.betfair.com/football/Norway%20fans%20flags%201280.jpg" loading="lazy">
</article>
</li>
<li>
<article>
<a href="https://betting.betfair.com/football/football-tips/daily-acca/the-daily-acca-samba-sunday-290522-35.html">The Daily Acca: Samba Sunday</a>
<img src="//betting.cdnppb.net/football/Vitor Pereira 956.728x410.jpg" alt="https://betting.betfair.com/football/Vitor%20Pereira%20956.jpg" loading="lazy">
</article>
</li>
</ul>

<div class="entry_category_link">
<a class="button" href="https://betting.betfair.com/football/uefa-nations-league/">More UEFA Nations League</a>
</div>
</div>
</main>
<aside class="entry_sidebar">
<section class="story-extra">
<nav class="sidebar_navigation">
<h4 class="section_title">More Football</h4>
<ul class="sidebar_menu">
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/betfair-offers/" class=" ">
Betfair Offers
</a>
</li>
<li class="sidebar_menu__item  sidebar_menu__item--has_children ">
<span class="sidebar_menu__toggle sidebar_menu__toggle--has_children "></span>
<a href="https://betting.betfair.com/football/football-tips/" class=" ">
Football Tips
</a>
<ul class="sidebar_menu">
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/football-tips/daily-acca/" class=" ">
Daily Acca
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/football-tips/the-jokers-bet-of-the-day/" class=" ">
Bet of the Day
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/football-tips/saturday-football-tips/" class=" ">
Saturday Football Tips
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/football-tips/accumulator-betting-tips/" class=" ">
Weekend ACCA
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/football-tips/talksport-charity-bet/" class=" ">
TalkSPORT Charity Bet
</a>
</li>
</ul>
</li>
<li class="sidebar_menu__item  sidebar_menu__item--has_children ">
<span class="sidebar_menu__toggle sidebar_menu__toggle--has_children "></span>
<a href="https://betting.betfair.com/football/premier-league/" class=" ">
Premier League
</a>
<ul class="sidebar_menu">
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/premier-league/team-guide/" class=" ">
Team Guide
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/premier-league/transfers/" class=" ">
Transfers
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/premier-league/arsenal/" class=" ">
Arsenal
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/premier-league/aston-villa/" class=" ">
Aston Villa
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/premier-league/brentford/" class=" ">
Brentford
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/premier-league/brighton/" class=" ">
Brighton
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/premier-league/burnley/" class=" ">
Burnley
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/premier-league/chelsea/" class=" ">
Chelsea
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/premier-league/crystal-palace/" class=" ">
Crystal Palace
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/premier-league/everton/" class=" ">
Everton
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/premier-league/leeds-utd/" class=" ">
Leeds Utd
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/premier-league/leicester-city/" class=" ">
Leicester City
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/premier-league/liverpool/" class=" ">
Liverpool
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/premier-league/manchester-city/" class=" ">
Manchester City
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/premier-league/manchester-united/" class=" ">
Manchester United
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/premier-league/newcastle-united/" class=" ">
Newcastle United
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/premier-league/norwich-city/" class=" ">
Norwich City
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/premier-league/southampton/" class=" ">
Southampton
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/premier-league/tottenham-hotspur/" class=" ">
Tottenham Hotspur
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/premier-league/watford/" class=" ">
Watford
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/premier-league/west-ham-united/" class=" ">
West Ham United
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/premier-league/wolves/" class=" ">
Wolves
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/premier-league/fantasy-premier-league/" class=" ">
Fantasy Premier League
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/premier-league/premier-league-betting-previews/" class=" ">
Premier League Betting Guides
</a>
</li>
</ul>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/championship/" class=" ">
Championship
 </a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/english-football-league/" class=" ">
English Football League
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/champions-league/" class=" ">
Champions League
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/spanish-football/" class=" ">
Spanish Football
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/italian-football/" class=" ">
Italian Football
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/german-football/" class=" ">
German Football
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/french-football/" class=" ">
French Football
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/europa-league/" class=" ">
Europa League
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/europa-conference-league/" class=" ">
Europa Conference League
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/big-winners/" class=" ">
Big Winners
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/fa-cup/" class=" ">
FA Cup
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/efl-cup/" class=" ">
EFL Cup
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/dimitar-berbatov/" class=" ">
Dimitar Berbatov
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/rivaldo/" class=" ">
Rivaldo
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/world-cup-2022/" class=" ">
World Cup 2022
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/manager-specials/" class=" ">
Manager Specials
</a>
</li>
<li class="sidebar_menu__item on sidebar_menu__item--has_children ">
 <span class="sidebar_menu__toggle sidebar_menu__toggle--has_children "></span>
<a href="https://betting.betfair.com/football/uefa-nations-league/" class="active ">
UEFA Nations League
</a>
<ul class="sidebar_menu">
</ul>
</li>
<li class="sidebar_menu__item  sidebar_menu__item--has_children ">
<span class="sidebar_menu__toggle sidebar_menu__toggle--has_children "></span>
<a href="https://betting.betfair.com/football/womens-football/" class=" ">
Women&#039;s Football
</a>
<ul class="sidebar_menu">
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/womens-football/womens-super-league/" class=" ">
Women&#039;s Super League
</a>
</li>
</ul>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/scottish-football/" class=" ">
Scottish Football
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/internationals/" class=" ">
Internationals
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/football/betting-masterclass/" class=" ">
Football Betting Masterclass
</a>
</li>
</ul>
</nav>
</section>
<div class="widget-context widget-context--both">
<div class="widget" data-context="both">
<div class="ft_async_tag">
<img src="data:image/png,ft" style="display: none" onerror='
        (function(img) {
            window.ftClick = "";
            window.ftExpTrack_6520861 = "";
            window.ftX = "";
            window.ftY = "";
            window.ftZ = "";
            window.ftOBA = 1;
            window.ftContent = "";
            window.ftCustom = "";
            window.ft300x600_OOBclickTrack = "";
            window.ftRandom = Math.random()*1000000;
            window.ftClick_6520861 = ftClick;

            if(typeof(ft_referrer)=="undefined"){window.ft_referrer=(function(){var r="";if(window==top){r=window.location.href;}else{try{r=window.parent.location.href;}catch(e){}r=(r)?r:document.referrer;}while(encodeURIComponent(r).length>1000){r=r.substring(0,r.length-1);}return r;}());}
            var ftDomain = (window==top)?"":(function(){var d=document.referrer,h=(d)?d.match("(?::q/q/)+([qw-]+(q.[qw-]+)+)(q/)?".replace(/q/g,decodeURIComponent("%"+"5C")))[1]:"";return (h&&h!=location.host)?"&ft_ifb=1&ft_domain="+encodeURIComponent(h):"";}());
            var ftV_6520861={pID:"6520861",width:"300",height:"600",params:{ftx:window.ftX,fty:window.ftY,ftadz:window.ftZ,ftscw:window.ftContent,ft_custom:window.ftCustom,ft_id:window.ftID||"",ft_idEnabled:window.ftIDEnabled||"",ftOBA:window.ftOBA,ft_domain:((ftDomain||"").match(RegExp("&ft_domain=([^&$]+)","i"))||["",""])[1],ft_ifb:((ftDomain||"").match(RegExp("&ft_ifb=([^&$]+)","i"))||["",""])[1],ft_agentEnv:window.mraid||window.ormma?"1":"0",ft_referrer:encodeURIComponent(window.ft_referrer),gdpr:"${GDPR}",gdpr_consent:"${GDPR_CONSENT_78}",us_privacy:"${US_PRIVACY}",cachebuster:window.ftRandom},winVars:{ftClick_6520861:window.ftClick_6520861,ftExpTrack_6520861:window.ftExpTrack_6520861,ft300x600_OOBclickTrack:window.ft300x600_OOBclickTrack},DTimeout:1E3,GTimeout:1E3},
            ftPProc=function(d){var c=this;d=JSON.parse(JSON.stringify(d));var f=[],l=function(a,b){b="undefined"===typeof b||isNaN(b)?1:parseInt(b,10);a=a||"";for(var e=0<=b?b:0;e--;)a=encodeURIComponent(a);return a},h=function(a){a=a.constructor==Array?a:[];for(var b=0;b<a.length;b++){var e=a[b].t&&"w"==a[b].t?"winVars":"params",c=d[e][a[b].p],g=l(a[b].n||"",a[b].e),h=l(a[b].v||"",a[b].e);g=(g?g+":":"")+h;""!==g&&(c="undefined"===typeof c||""===c||"o"===a[b].m?"":c+";",d[e][a[b].p]=c+g)}a=!0;for(b=0;b<f.length;b++)if(!f[b].deployed){a=!1;break}a&&k()},k=function(){k=function(){};deployTag()};c.getVars=function(a){return JSON.parse(JSON.stringify(a?"string"===typeof a&&"undefined"!==typeof d[a]?d[a]:{}:d))};c.getSrcString=function(){var a=c.getVars("params"),b=[],e;for(e in a)a.hasOwnProperty(e)&&"undefined"!==typeof a[e]&&""!==a[e]&&b.push(e+"="+a[e]);return b.join("&")};c.deployWinVars=function(){var a=c.getVars("winVars"),b;for(b in a)a.hasOwnProperty(b)&&"undefined"!==typeof a[b]&&(window[b]=a[b])};c.addPProc=function(a){a.deployed=!1;f.push(a)};c.init=function(){d.v=5;var a=[];0===f.length?k():(f.forEach(function(b){a.push(b.id);b.timeout=parseInt(isNaN(b.timeout)?d.DTimeout:b.timeout,10);b.timer=setTimeout(function(){var a={};clearTimeout(b.timer);b.deployed||(b.deployed=!0,h(a))},b.timeout||d.DTimeout);b.deploy(c.getVars(),function(a){clearTimeout(b.timer);b.deployed||(b.deployed=!0,h(a))})}),window["ftPPIDs_"+d.pID]=d.v+";"+a.join(","))}},ft6520861PP = new ftPProc(ftV_6520861);
            
            var deployTag = function(){deployTag = function(){};clearTimeout(gTimer);ft6520861PP.deployWinVars();
                var ftTag = document.createElement("script");
                ftTag.id = "ft_servedby_6520861";
                ftTag.src = "https://servedby.flashtalking.com/imp/1/126954;6520861;201;jsappend;BettingBetfair;BFUKIEBettingBetfairDesktopSportsBrandPremiumDailyRewardsFlipbook300x600/?"+ft6520861PP.getSrcString();
                ftTag.name = "ftscript_300x600";
                img.parentNode.insertBefore(ftTag, img.nextSibling);
            },gTimer = setTimeout(function(){clearTimeout(gTimer);deployTag();},ftV_6520861.GTimeout);ft6520861PP.init();
        })(this);
    '>
</div>
</div>
</div>
<div class="widget-context widget-context--full">
<div class="widget" data-context="full">
<div id="side-sport-text-ad" class="widget">
<div class="widget__body">
<h3>GET A FREE £/€20 EXCHANGE BET</h3>
<ul>
<li><strong>Join Now</strong> - Open Account Using Promo Code <strong>VAL225</strong></li>
<li><strong>Bet</strong> - Place a £/€20 Bet on the Exchange</li>
<li><strong>Earn</strong> - £/€20 Back in cash if your bet loses</li>
</ul>
</div>
<div class="widget__footer">
<a class="button grad_yellow" href="https://promotions.betfair.com/prs/exchange-acq-uk-bau-free20-val225-temp">BET & WIN</a>
</div>
</div>​
</div>
</div>
<div class="widget-context widget-context--both">
<div class="widget" data-context="both">
<h3 class="section_title" style="width: 100%; box-sizing: border-box;">Lay betting calculator</h3><div class="laybet_calculator"></div>
</div>
</div>
<div class="widget-context widget-context--full">
<div class="widget" data-context="full">
<div class="block"><header class="block__header"><h3>Services</h3></header><div class="block__body sidebar_navigation_ruled"><ul><li><a href="https://betting.betfair.com/how-to-use-betfair-exchange/beginner-guides/" target="_blank">Beginners' Guide to Betfair Exchange</a></li><li><a href="https://betting.betfair.com/betfair-announcements/whats-new-on-betfair/betfair-exchange-minimum-stake-were-lowering-it-to-1-020222-6.html" target="_blank">Minimum Exchange stake now £1 - details here</a></li><li><a href="https://betting.betfair.com/betfair-announcements/whats-new-on-betfair/opta-definitions-shots-and-shots-on-target-061020-204.html" target="_blank">Shots on Target - Definitions</a></li><li><a href="https://betting.betfair.com/horse-racing/horseracing-tips/money-back-if-your-horse-doesnt-finish-in-top-three-161121-204.html" target="_blank">Money Back if your horse doesn't place - T&Cs</a></li><li><a href="https://betting.betfair.com/betfair-announcements/whats-new-on-betfair/line-markets-on-betfair-everything-you-need-to-know-240821-204.html" target="_blank">Line Markets -Everything you need to know as NFL and NBA are added</a></li><li><a href="https://betting.betfair.com/betfair-announcements/whats-new-on-betfair/matchme-making-it-easier-get-your-bet-matched-260121-204.html" target="_blank">MatchMe - Making it easier to get your bet matched</a></li><li><a href="https://betting.betfair.com/golf/each-way-golf-betting-calculator/" target="_blank">Each-Way Betting Calculator</a></li><li><a href="https://betting.betfair.com/betfair-announcements/whats-new-on-betfair/my-betfair-rewards-choose-your-bonuses-with-new-feature-140619-6.html" target="_blank">My Betfair Rewards</a></li><li><a href="https://support.betfair.com/app/contact_us/" target="_blank">Betfair Customer Support</a></li><li><a href="https://betting.betfair.com/horse-racing/minimum-bet-guarantee-terms-and-conditions-190618-6.html" target="_blank">Minimum Bet Guarantee - Horse Racing</a></li></ul></div></div>
</div>
</div>
<div class="widget-context widget-context--full">
<div class="widget" data-context="full">
<div class="block"><header class="block__header"><h3>Communities</h3></header><div class="block__body block__body--light"><ul class="button_group"><li><a href="https://twitter.com/betfairexchange" target="_blank"><span class="sprite_icon sprite_icon--twitter">Twitter</span></a></li><li><a href="https://www.facebook.com/Betfair" target="_blank"><span class="sprite_icon sprite_icon--facebook">Facebook</span></a></li><li><a href="https://www.youtube.com/channel/UC9XohsLvYWrUqkPUuR3mpTw?view_as=subscriber" target="_blank"><span class="sprite_icon sprite_icon--youtube">YouTube</span></a></li><li><a href="https://betting.betfair.com/index.xml"><span class="sprite_icon sprite_icon--rss">RSS</span></a></li><li><a href="https://www.instagram.com/betfair" target="_blank"><span class="sprite_icon sprite_icon--instagram">Instagram</span></a></li><li><a href="https://open.spotify.com/show/6Ev5q92RFgvWk49NcObn9c" target="_blank"><span class="sprite_icon sprite_icon--spotify">Spotify</span></a></li><li><a href="https://podcasts.apple.com/ie/podcast/betfair/id1463419538" target="_blank"><span class="sprite_icon sprite_icon--apple_podcasts">Apple Podcasts</span></a></li><li><a href="https://soundcloud.com/betfair-betting-podcast/" target="_blank"><span class="sprite_icon sprite_icon--soundcloud">Soundcloud</span></a></li><li><a href="https://podcasts.google.com/?feed=aHR0cDovL2ZlZWRzLnNvdW5kY2xvdWQuY29tL3VzZXJzL3NvdW5kY2xvdWQ6dXNlcnM6NjIyNDAzOTk0L3NvdW5kcy5yc3M" target="_blank"><span class="sprite_icon sprite_icon--google_podcasts">Google Podcasts</span></a></li></ul></div></div>
</div>
</div>
<div class="widget-context widget-context--full">
<div class="widget" data-context="full">
</div>
</div>
<div class="widget-context widget-context--full">
<div class="widget" data-context="full">
<h3 class="section_title" style="width: 100%; box-sizing: border-box;">Related Sites</h3><div><a href="https://tinyurl.com/n9kappa" target="_blank"><img src="/images/betfair-related.png" alt="Betfair" width="300" height="100" loading="lazy"></a></div><div><a href="https://www.timeform.com/horse-racing/" target="_blank"><img src="https://betting.betfair.com/images/timeform-related.png" alt="Timeform Horse Racing" width="300" height="100" loading="lazy"></a></div><div><a href="https://www.infogol.net/" target="_blank"><img src="https://betting.betfair.com/images/infogol-related.png" alt="Infogol" width="300" height="100" loading="lazy"></a></div>
</div>
</div>
<div class="widget-context widget-context--both">
<div class="widget" data-context="both">
<div class="lazy_widget"></div>
</div>
</div>
</aside>
</div>

<nav class="breadcrumb__navigation">
<ol>
<li>
<a href="https://betting.betfair.com/">Home</a>
</li>
<li>
<a href="https://betting.betfair.com/football/">Football</a>
</li>
<li>
<a href="https://betting.betfair.com/football/uefa-nations-league/">UEFA Nations League</a>
</li>
<li>
Saturday Nations League Bet Builder Tips: Germany can handle Italian job
</li>
</ol>
</nav>
<script type="application/ld+json">
    {
      "@context": "http://schema.org",
      "@type": "BreadcrumbList",
      "itemListElement": [
                  {
            "@type": "ListItem",
            "position": 1,
            "item": {
              "@id": "https://betting.betfair.com/",
              "name": "Home"
            }
          },                  {
            "@type": "ListItem",
            "position": 2,
            "item": {
              "@id": "https://betting.betfair.com/football/",
              "name": "Football"
            }
          },                  {
            "@type": "ListItem",
            "position": 3,
            "item": {
              "@id": "https://betting.betfair.com/football/uefa-nations-league/",
              "name": "UEFA Nations League"
            }
          },                  {
            "@type": "ListItem",
            "position": 4,
            "item": {
              "@id": "https://betting.betfair.com/football/uefa-nations-league/saturday-nations-league-bet-builder-tips-germany-can-handle-italian-job-020622-629.html",
              "name": "Saturday Nations League Bet Builder Tips: Germany can handle Italian job"
            }
          }              ]
    }
  </script>
</main>

<div class="full_navigation" id="full_navigation">
<div class="full_nav_link full_navigation__toggle"><span></span></div>

<nav class="full_navigation__menu full_navigation__menu--primary">
<ul class="menu">
<li class="menu__item menu__item--active">
<a href="https://betting.betfair.com/football/">Football</a>
</li>
<li class="menu__item">
<a href="https://betting.betfair.com/horse-racing/">Horse Racing</a>
</li>
<li class="menu__item">
<a href="https://betting.betfair.com/cricket/">Cricket</a>
</li>
<li class="menu__item">
<a href="https://betting.betfair.com/multiples/">Multiples Tips</a>
</li>
<li class="menu__item">
<a href="https://betting.betfair.com/tennis/">Tennis</a>
</li>
<li class="menu__item">
<a href="https://betting.betfair.com/golf/">Golf</a>
</li>
<li class="menu__item">
<a href="https://betting.betfair.com/politics/">Politics</a>
</li>
<li class="menu__item">
<a href="https://betting.betfair.com/specials/">Specials</a>
</li>
<li class="menu__item">
<a href="https://betting.betfair.com/rugby/">Rugby</a>
</li>
<li class="menu__item">
<a href="https://betting.betfair.com/betting/formula-one/">Formula 1</a>
</li>
<li class="menu__item">
<a href="https://betting.betfair.com/betting/">Other Sports</a>
</li>
</ul>
</nav>
<nav class="full_navigation__menu full_navigation__menu--secondary">
<h3>More from Betfair</h3>
<ul class="menu">
<li class="menu__item">
<a href="https://betting.betfair.com">Betting.Betfair</a>
</li>
<li class="menu__item">
<a href="https://betting.betfair.com/podcasts/">Podcasts</a>
</li>
<li class="menu__item">
<a href="https://www.betfair.com/sport/">Betfair Sportsbook</a>
</li>
<li class="menu__item">
<a href="https://betting.betfair.com/how-to-use-betfair-exchange/">Exchange How-to</a>
</li>
<li class="menu__item">
<a href="https://www.betfair.com/exchange/plus/">Betfair Exchange</a>
</li>
<li class="menu__item">
<a href="https://responsiblegambling.betfair.com/">Safer Gambling</a>
</li>
</ul>
<ul class="menu">
<li class="menu__item">
<a href="https://register.betfair.com/account/registration?product=CIDF9QtQsFYf223X&amp;returnURL=https%3A%2F%2Fbetting.betfair.com%2Ffootball%2Fuefa-nations-league%2Fsaturday-nations-league-bet-builder-tips-germany-can-handle-italian-job-020622-629.html">Join</a>
</li>
<li class="menu__item">
<a href="https://identitysso.betfair.com/view/login?product=CIDF9QtQsFYf223X&amp;url=https%3A%2F%2Fbetting.betfair.com%2Ffootball%2Fuefa-nations-league%2Fsaturday-nations-league-bet-builder-tips-germany-can-handle-italian-job-020622-629.html">Log in</a>
</li>
</ul>
</nav>
</div>

<footer class="layout__footer">
<div class="footer_top">
</div>
<footer class="footer_mid">
<div class="footer_mid__column">
<p class="footer_mid__text">WE ARE A SECURE OPERATOR | 18+ Gambleaware.co.uk
<br><br>
BETFAIR ® and the BETFAIR logo are registered trade marks of The Sporting Exchange Limited. ©The Sporting Exchange Limited. All rights reserved.
<br><br>
For customers in the UK, TSE Malta LP is licensed and regulated by the Gambling Commission, Licence Number: <a href="https://secure.gamblingcommission.gov.uk/PublicRegister/Search/Detail/39561" target="_blank">000-039561-R-319411-005</a>. Correspondence Address: Triq il-Kappillan Mifsud, St. Venera, SVR 1851, MALTA. Betfair International Plc is licensed and regulated by the <a href="https://www.mga.org.mt/" target="_blank">Malta Gaming Authority</a>. Licence Number: MGA/CL3/454/2008 17th March 2015, Triq il-Kappillan Mifsud, St. Venera, SVR 1851, MALTA. Fixed Odds & Multiples bets are placed with PPB Counterparty Services Limited which is licensed and regulated by the <a href="https://www.mga.org.mt/" target="_blank">Malta Gaming Authority</a>. Licence Number: MGA/CL2/294/2006 12 March 2013, and for customers in the UK, licensed and regulated by the Gambling Commission, Licence Number: <a href="https://secure.gamblingcommission.gov.uk/PublicRegister/Search/Detail/39439" target="_blank">000-039439-R-319330-007</a>.</p>
</div>
<div class="footer_mid__column footer_mid__column--links">
<div class="footer_mid__links">
<h3>More Betfair</h3>
<ul>
<li><a href="https://betting.betfair.com/betfair-announcements/whats-new-on-betfair/my-betfair-rewards-choose-your-bonuses-with-new-feature-140619-6.html">My Betfair Rewards </a></li>
<li><a href="https://tvguide.betfair.com/english-uk/tv/">Live Sport on TV</a></li>
<li><a href="https://www.betfair.com/sport/cashout">Cash Out</a></li>
</ul>
</div>
<div class="footer_mid__links">
<h3>More Betfair</h3>
<ul>
<li><a href="https://tinyurl.com/mmbnsp7">Betfair Corporate</a></li>
<li><a href="https://support.betfair.com/app/answers/detail/a_id/5749/">Payment Methods</a></li>
</ul>
</div>
<div class="footer_mid__links">
<h3>About</h3>
<ul>
<li><a href="https://www.betfair.com/aboutUs/Privacy.Policy/">Privacy Policy</a></li>
<li><a href="https://www.betfair.com/aboutUs/Cookie.Policy/">Cookie Policy</a></li>
 <li><a href="https://tinyurl.com/mmbnsp7">About Betfair</a></li>
<li><a href="https://support.betfair.com/app/home">Help &amp; Learning</a></li>
<li><a href="https://responsiblegambling.betfair.com/">Safer Gambling</a></li>
</ul>
</div>
<div class="footer_mid__links">
<h3>Pick language</h3>
<ul>
<li><a href="https://betting.betfair.com/">Global</a></li>
<li><a href="https://apuestas.betfair.es">Español</a></li>
<li><a href="https://scommesseonline.betfair.it/">Italia</a></li>
<li><a href="https://apostas.betfair.com/">Português</a></li>
<li><a href="/dk/">Danmark</a></li>
<li><a href="https://betting.betfair.com/se/">Sverige</a></li>
<li><a href="https://pariuri.betfair.ro" http: pariuri.betfair.com />România</a></li>
</ul>
</div>
</div>
</footer>
<div class="footer_lower">
<div class="footer_lower__text">
<p>For any queries relating to Betting.Betfair, e-mail <a href="mailto:Copy@betfair.com">Copy@betfair.com</a>. For any other Betfair-related queries, head to <a href="https://support.betfair.com/app/home" target="_blank">customer support</a></p>
<p>&copy; Betfair 2007&ndash;2022</p>
</div>
</div>
</footer>

<nav id="floating_nav">
<ul><li><a href="https://betting.betfair.com/football//"><strong>Latest</strong> Football</a></li><li><a href="https://betting.betfair.com/horse-racing/"><strong>Latest</strong> Horse Racing</a></li><li><a href="https://betting.betfair.com/golf/"><strong>Latest</strong> Golf</a></li><li><a href="https://betting.betfair.com/cricket/"><strong>Latest</strong> Cricket</a></li></ul>
</nav>
</div>

<script type="text/javascript">
/*
$(document).ready(function(){
let slidesToKeep = ['.fri'];
  $('.festival_page_carousel--races').slick('slickFilter', String(slidesToKeep));
});*/
</script>
<script defer src="https://static.cloudflareinsights.com/beacon.min.js/v652eace1692a40cfa3763df669d7439c1639079717194" integrity="sha512-Gi7xpJR8tSkrpF7aordPZQlW2DLtzUlZcumS8dMQjwDHEnw9I7ZLyiOj/6tZStRBGtGgN6ceN6cMH8z7etPGlw==" data-cf-beacon='{"rayId":"71518abaa86a8233","token":"d048f65d27954a24aa6b1d7d2ddcb256","version":"2021.12.0","si":100}' crossorigin="anonymous"></script>
</body>
</html>
