<!doctype html>
<html lang="en" class="no-js">
<head>
<meta charset="utf-8">
<title>World Snooker Quarter Final Tips: Bingham to maintain strong record against Trump</title>
<link rel="preconnect" href="//betting.cdnppb.net" crossorigin>
<link rel="preconnect" href="//www.googletagmanager.com" crossorigin>
<link rel="preconnect" href="//ajax.googleapis.com" crossorigin>
<link rel="preconnect" href="//www.google-analytics.com" crossorigin>
<link rel="preconnect" href="//connect.facebook.com" crossorigin>
<link rel="preconnect" href="//servedby.flashtalking.com" crossorigin>
<link rel="preconnect" href="//cdn-ukwest.onetrust.com" crossorigin>
<link rel="preconnect" href="//s0.2mdn.net" crossorigin>
<link rel="preload" href="//ajax.googleapis.com/ajax/libs/jquery/3.5.1/jquery.min.js" as="script">
<link rel="preload" href="//betting.cdnppb.net/_v2/img/webfonts/Noto/Medium/NotoSans-Medium.woff" as="font" type="font/woff" crossorigin>
<link rel="preload" href="//betting.cdnppb.net/_v2/img/webfonts/Noto/Bold/NotoSans-Bold.woff" as="font" type="font/woff" crossorigin>
<link rel="preload" href="//betting.cdnppb.net/_v2/img/webfonts/Noto/BoldItalic/NotoSans-BoldItalic.woff" as="font" type="font/woff" crossorigin>
<link rel="preload" href="//betting.cdnppb.net/_v2/img/webfonts/Noto/ExtraBold/NotoSans-ExtraBold.woff" as="font" type="font/woff" crossorigin>
<link rel="preload" href="//betting.cdnppb.net/_v2/img/webfonts/Noto/ExtraBoldItalic/NotoSans-ExtraBoldItalic.woff" as="font" type="font/woff" crossorigin>
<link rel="preload" href="//betting.cdnppb.net/_v2/img/betfair-icon.svg" as="image">
<link rel="preload" href="//betting.cdnppb.net/_v2/img/backgrounds/bf-triangle-down.png" as="image">
<link rel="preload" href="//betting.cdnppb.net/_v2/img/backgrounds/bf-triangle-up.png" as="image">
<link rel="preload" href="//betting.cdnppb.net/_v2/img/spritesheets/icons-v1.svg" as="image"> <link rel="preload" href="//betting.cdnppb.net/_v2/bf.css?v=4fccc3ec88d5a3a811b5be274ff62221" as="style">
<link rel="preload" href="//betting.cdnppb.net/_v2/bf-v2-body.js?v=ff1c06910eb7b37cd8916d9f872069ce" as="script">
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="theme-color" content="#FFB80C">
<meta name="description" content="Paul Krishnamurty previews the second pair of quarter-finals, starting this afternoon, involving Judd Trump, Stuart Bingham, John Higgins and Jack Lisowski">
<meta name="keywords" content="">
<link rel="canonical" href="https://betting.betfair.com/betting/snooker/world-snooker-championship-betting/match-previews/world-snooker-quarter-final-tips-bingham-to-maintain-strong-record-against-trump-260422-171.html">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@BetfairExchange">
<meta name="twitter:creator" content="@paulmotty">
<meta name="twitter:title" content="World Snooker Quarter Final Tips: Bingham to maintain strong record against Trump">
<meta name="twitter:description" content="Paul Krishnamurty previews the second pair of quarter-finals, starting this afternoon, involving Judd Trump, Stuart Bingham, John Higgins and Jack Lisowski...">
<meta name="twitter:image" content="https://betting.cdnppb.net/betting/Bingham1280.jpg">
<meta property="og:url" content="https://betting.betfair.com/betting/snooker/world-snooker-championship-betting/match-previews/world-snooker-quarter-final-tips-bingham-to-maintain-strong-record-against-trump-260422-171.html" />
<meta property="og:type" content="article" />
<meta property="og:title" content="World Snooker Quarter Final Tips: Bingham to maintain strong record against Trump" />
<meta property="og:description" content="Paul Krishnamurty previews the second pair of quarter-finals, starting this afternoon, involving Judd Trump, Stuart Bingham, John Higgins and Jack Lisowski" />
<meta property="og:image" content="https://betting.cdnppb.net/betting/Bingham1280.956x538.jpg" />
<meta property="og:mainEntityOfPage" content="https://betting.betfair.com/betting/snooker/world-snooker-championship-betting/match-previews/world-snooker-quarter-final-tips-bingham-to-maintain-strong-record-against-trump-260422-171.html" />
<meta property="og:dateModified" content="2022-04-26T00:28:00+01:00" />
<meta name="original-source" content="https://betting.betfair.com/betting/snooker/world-snooker-championship-betting/match-previews/world-snooker-quarter-final-tips-bingham-to-maintain-strong-record-against-trump-260422-171.html">
<link rel="amphtml" href="https://betting.betfair.com/betting/snooker/world-snooker-championship-betting/match-previews/world-snooker-quarter-final-tips-bingham-to-maintain-strong-record-against-trump-260422-171.html?amp=1">
<link rel="alternate" type="application/rss+xml" title="UK RSS" href="https://betting.betfair.com/index.xml" /><link rel="alternate" type="application/rss+xml" title="UK Other Sports RSS" href="https://betting.betfair.com/betting/index.xml" /><link rel="alternate" type="application/rss+xml" title="Snooker RSS" href="https://betting.betfair.com/betting/snooker/index.xml" /><link rel="alternate" type="application/rss+xml" title="World Snooker Championship RSS" href="https://betting.betfair.com/betting/snooker/world-snooker-championship-betting/index.xml" /><link rel="alternate" type="application/rss+xml" title="Match Previews RSS" href="https://betting.betfair.com/betting/snooker/world-snooker-championship-betting/match-previews/index.xml" /> <link rel="shortcut icon" href="//betting.cdnppb.net/_v2/img/app-icons/favicon.ico">
<link rel="apple-touch-icon" sizes="76x76" href="//betting.cdnppb.net/_v2/img/app-icons/76.png">
<link rel="apple-touch-icon" sizes="120x120" href="//betting.cdnppb.net/_v2/img/app-icons/120.png">
<link rel="apple-touch-icon" sizes="152x152" href="//betting.cdnppb.net/_v2/img/app-icons/152.png">
<link rel="apple-touch-icon" sizes="180x180" href="//betting.cdnppb.net/_v2/img/app-icons/180.png">
<script>
  document.documentElement.className = document.documentElement.className.replace('no-js', 'js');
  var isBig = (screen.width >= 768) ? true : false;
  var ASSET_DOMAIN = 'betting.cdnppb.net';
  var ui = {
    menu_text: ''
  };
  var contextual_info = '{"blog_name":"UK Other Sports","category_label":"Match Previews","market_id":"https:\/\/www.betfair.com\/sport\/snooker\/world-championship\/stuart-bingham-v-judd-trump\/314082997","entry_title":"World Snooker Quarter Final Tips: Bingham to maintain strong record against Trump"}';
</script>
<script>

  // Usage: ga_pageLoad('property', 'locale', 'jurisdiction', 'platform', 'product_key')

  window.getCookie = function (name) {
    var match = document.cookie.match(new RegExp('(^| )' + name + '=([^;]+)'));
    if (match) return match[2];
  };

	function ga_pageLoad(property, locale, jurisdiction, platform, product_key, vertical) {
		if (typeof product_key === 'undefined') {
			product_key = 'bf';
		}

		if (typeof vertical === 'undefined') {
			vertical = 'exchange';
		}

    var product = [product_key, 'blog', locale, platform].join(' ');
    
    // Oritentation
    var orientation = 'desktop';
		if (platform != 'desktop') {
			orientation = (window.matchMedia("(orientation: portrait)").matches ? 'portrait' : 'landscape');
		}

    // Reg status
    var reg_status = 'unregistered', 
				bsfd_st = '',
				bsfd = getCookie('bsfd');
		if (bsfd) {
    	bsfd_st = bsfd.substring(bsfd.indexOf('|') + 1);
		}

    switch (bsfd_st) {
      case 'reg':
        reg_status = 'returning registered';
        break;
      case 'p':
        reg_status = 'new prospect';
        break;
      case 'rp':
        reg_status = 'returning';
        break;
      default:
        reg_status = 'unregistered';
    }

    // Payload
		window.dataLayer = window.dataLayer || [];
		dataLayer.push({
			'event': 'ga_pageLoad',
			'ga_target_property': property,
			'acc_id': null,
			'vertical': vertical,
			'product': product,
			'locale': locale,
			'reg_status': reg_status,
			'login_status': "logged out",
			'jurisdiction': jurisdiction,
			'orientation': orientation,
			'app_id': null,
			'rfr': getCookie('rfr'),
			'pid': getCookie('pid'),
			'ttp': getCookie('ttp'),
			'bid': getCookie('bid'),
			'promo_code': getCookie('promotionCode'),
			'clkid': getCookie('clkID'),
			'sid': getCookie('sid'),
			'StickyTags': getCookie('StickyTags'),
			'TrackingTags': getCookie('TrackingTags'),
			'brand': product_key,
			'vid': getCookie('vid')
		});
	};
</script> <link rel="stylesheet" href="//betting.cdnppb.net/_v2/bf.css?v=4fccc3ec88d5a3a811b5be274ff62221" /> <script src="//ajax.googleapis.com/ajax/libs/jquery/3.5.1/jquery.min.js"></script>
<script src="//betting.cdnppb.net/_v2/bf-v2-body.js?v=ff1c06910eb7b37cd8916d9f872069ce"></script>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.defer=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-P32JX6');</script>

<link rel="manifest" href="/manifest.json">
<meta name="apple-itunes-app" content="app-id=1084818519" />
<meta property="fb:app_id" content="1993283457561753" />
<meta property="fb:pages" content="106600595002" />
<meta property="fb:admins" content="adam.baylis" />
<meta property="fb:admins" content="joe.dyer.9250" />
<meta property="fb:admins" content="michael.norman.543" />
<meta name="google-site-verification" content="2WO_m3dA936nmysauyp7GaqR63a-qUMcxv8lwa-eQy0" />
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-43334570-1', 'betfair.com');

// Mobile only exchange
if (!isBig) {
  ga('create', 'UA-43334570-2', 'betfair.com', 'mobile');
}

// create the dataLayer array
window.dataLayer = window.dataLayer || []

// start additional code. ensure dataLayer code is above this
ga(function(tracker) {

  // Grab a reference to the default sendHitTask function.
  var originalSendHitTask = tracker.get('sendHitTask');

function getPayloadObject(payload) {
    var match,
        pl     = /\+/g,  // Regex for replacing addition symbol with a space
        search = /([^&=]+)=?([^&]*)/g,
        decode = function (s) { return decodeURIComponent(s.replace(pl, " ")); },
        query  = payload;

    var urlParams = {};
    while (match = search.exec(query))
       urlParams[decode(match[1])] = decode(match[2]);

    return urlParams;
};

  // Modifies sendHitTask to send a copy of the request to window.dataLayer

  tracker.set('sendHitTask', function(model) {
    // sending the normal request to www.google-analytics.com/collect.
    originalSendHitTask(model);

    // sending the payload to the datalayer
    var payload = model.get('hitPayload');
    var payloadObject = getPayloadObject(payload)

    payloadObject.event = payloadObject.t == 'event' ? 'googleAnalyticsEvent' : 'googleAnalyticsPageview';
    window.dataLayer.push(payloadObject);
  });
});

// send pageview
ga('send', 'pageview');

if (!isBig) {
  ga('mobile.send', 'pageview');
}
</script>
<script>
// GA Page Load UK
if (isBig) {
  ga_pageLoad('UA-43334570-1', 'en', 'international', 'desktop');
} else {
  ga_pageLoad('UA-43334570-2', 'en', 'international', 'mobile web');
}
</script>
<script type="text/javascript">
    window._vis_opt_queue = window._vis_opt_queue || [], _vis_counter = 0;
    _vis_opt_queue.push(function() {
        try {
            if(!_vis_counter) {
                var _vis_data = "",_vis_combination,_vis_id,_vis_l=0;
                for(;_vis_l<_vwo_exp_ids.length;_vis_l++) {
                    _vis_id = _vwo_exp_ids[_vis_l];
                    if(_vwo_exp[_vis_id].ready) {
                        _vis_combination = _vis_opt_readCookie('_vis_opt_exp_'+_vis_id+'_combi');
                        if(typeof(_vwo_exp[_vis_id].combination_chosen) != "undefined")
                            _vis_combination = _vwo_exp[_vis_id].combination_chosen;
                        if(typeof(_vwo_exp[_vis_id].comb_n[_vis_combination]) != "undefined") {
                            _vis_data += 'VWOTestID-'+_vis_id + "=" + _vwo_exp[_vis_id].comb_n[_vis_combination] + "|";
                            _vis_counter++;
                        }
                    }
                }
                // Use the _vis_data object created above to fetch the data,
                // key of the object is the Test ID and the value is Variation Name
                if(_vis_counter) {
                    vwo_$(function() {
                        window.ga("set", "dimension25", _vis_data);
                        window.ga('send', 'event', 'VWO', 'Custom', {'nonInteraction': 1});
                    });
                }
            }
        }
        catch(err) {};
    });

</script>
</head>
<body id="entry" class="entry">


<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-P32JX6"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div class="layout" style="background-color:#FBFBFB">
<div class="layout__mobile_advert">
</div>

<header class="layout__header">
<nav id="services_navigation">
<ul class="services_nav">
<li class="services_nav__item">
<a href="https://betting.betfair.com">Betting.Betfair
</a></li>
<li class="services_nav__item">
<a href="https://betting.betfair.com/podcasts/">Podcasts
</a></li>
<li class="services_nav__item">
<a href="https://www.betfair.com/sport/">Betfair Sportsbook
</a></li>
<li class="services_nav__item">
<a href="https://betting.betfair.com/how-to-use-betfair-exchange/">Exchange How-to
</a></li>
<li class="services_nav__item">
<a href="https://www.betfair.com/exchange/plus/">Betfair Exchange
</a></li>
<li class="services_nav__item">
<a href="https://responsiblegambling.betfair.com/">Safer Gambling
</a></li>
<li class="services_nav__item" style="margin-left: auto;"><a href="https://register.betfair.com/account/registration?product=CIDF9QtQsFYf223X&amp;returnURL=https%3A%2F%2Fbetting.betfair.com%2Fbetting%2Fsnooker%2Fworld-snooker-championship-betting%2Fmatch-previews%2Fworld-snooker-quarter-final-tips-bingham-to-maintain-strong-record-against-trump-260422-171.html">Join</a></li>
<li class="services_nav__item"><a href="https://identitysso.betfair.com/view/login?product=CIDF9QtQsFYf223X&amp;url=https%3A%2F%2Fbetting.betfair.com%2Fbetting%2Fsnooker%2Fworld-snooker-championship-betting%2Fmatch-previews%2Fworld-snooker-quarter-final-tips-bingham-to-maintain-strong-record-against-trump-260422-171.html">Log in</a></li>
<li class="services_nav__item services_nav__item--toggle"><a class="full_nav_link" href="#full_navigation"><span>Menu</span></a></li>
</ul>
</nav> <div class="header">
<a class="header__logo" href="https://betting.betfair.com/">
<p style="position: static; top: 0; left: 0; margin: 0;"><img src="https://betting.betfair.com/images/bettingbetfairlogoblack.png" alt="Betting.Betfair" width="200" height="24"></p>
<p>Betting.Betfair</p>
</a>
<div class="header__nav">
<nav class="main_navigation">
<ul class="menu">
<li class="menu__item">
<span class="menu__toggle">More</span>

<a href="https://betting.betfair.com/football/">Football</a>
<nav class="sub_menu">
<div class="sub_menu__wrapper">
<div class="sub_menu__block sub_menu__block--featured">
<h4>Featured Football</h4>
<ul>
<li>
<a href="https://betting.betfair.com/football/football-tips/copa-libertadores-tips-home-advantage-key-across-four-fixtures-in-week-3-240422-1057.html">Copa Libertadores Tips: Home advantage key across four fixtures</a>
</li>
<li>
<a href="https://betting.betfair.com/football/premier-league/premier-league-odds-round-up-arsenal-overcome-man-utd-to-reclaim-fourth-place-240422-777.html">Premier League Round-Up: Arsenal overcome Man Utd to reclaim fourth place</a>
</li>
<li>
<a href="https://betting.betfair.com/football/football-tips/the-jokers-bet-of-the-day/monday-football-tips-take-a-luke-at-9-1-bet-builder-240422-840.html">Monday Football Tips: Take a Luke at 9/1 Bet Builder</a>
</li>
</ul>
</div>
<div class="sub_menu__block sub_menu__block--more">
<h4>More Football</h4>
<ul>
<li class="">
<a href="https://betting.betfair.com/football/football-tips/">Football Tips</a>
</li>
<li class="">
<a href="https://betting.betfair.com/football/premier-league/">Premier League</a>
</li>
<li class="">
<a href="https://betting.betfair.com/football/championship/">Championship</a>
</li>
<li class="">
<a href="https://betting.betfair.com/football/champions-league/">Champions League</a>
</li>
<li class="">
<a href="https://betting.betfair.com/football/fa-cup/">FA Cup</a>
</li>
<li class="">
<a href="https://betting.betfair.com/football/spanish-football/">Spanish Football</a>
</li>
<li class="">
<a href="https://betting.betfair.com/football/italian-football/">Italian Football</a>
</li>
<li class="">
<a href="https://betting.betfair.com/football/german-football/">German Football</a>
</li>
<li class="">
<a href="https://betting.betfair.com/football/french-football/">French Football</a>
</li>
<li class="">
<a href="https://betting.betfair.com/football/europa-league/">Europa League</a>
</li>
<li class="">
<a href="https://betting.betfair.com/football/world-cup-2022/">World Cup 2022</a>
</li>
</ul>
</div>
</div>
</nav>
</li>
<li class="menu__item">
<span class="menu__toggle">More</span>
<a href="https://betting.betfair.com/horse-racing/">Horse Racing</a>
<nav class="sub_menu">
<div class="sub_menu__wrapper">
<div class="sub_menu__block sub_menu__block--featured">
<h4>Featured Horse Racing</h4>
<ul>
 <li>
<a href="https://betting.betfair.com/horse-racing/events/punchestown-festival/punchestown-festival-day-1-tips-three-grade-1s-highlight-stellar-opening-day-250422-1111.html">Punchestown Festival Day 1 Tips: Three Grade 1s highlight stellar opening day</a>
</li>
<li>
<a href="https://betting.betfair.com/horse-racing/horseracing-tips/newmarket-2000-guineas-antepost-tips-back-coroebeus-to-upset-stablemate-250422-134.html">Newmarket 2000 Guineas Antepost Tips: Back Corobeus to upset stablemate</a>
</li>
<li>
<a href="https://betting.betfair.com/horse-racing/horseracing-tips/itv-races/punchestown-tuesday-racing-tips-track-lover-felix-is-a-fair-each-way-price-250422-166.html">Punchestown Tuesday Racing Tips: Track lover Felix is a fair price says Tony Calvin</a>
</li>
</ul>
</div>
<div class="sub_menu__block sub_menu__block--more">
<h4>More Horse Racing</h4>
<ul>
<li class="">
<a href="https://betting.betfair.com/horse-racing/horseracing-tips/">Horse Racing Tips</a>
</li>
<li class="">
<a href="https://betting.betfair.com/horse-racing/daily-racing-news/">Daily Racing News</a>
</li>
<li class="">
<a href="https://betting.betfair.com/horse-racing/horseracing-tips/itv-races/">ITV Races - Tony Calvin</a>
</li>
<li class="">
<a href="https://betting.betfair.com/horse-racing/kevin-blake-1/">Kevin Blake</a>
</li>
<li class="">
<a href="https://betting.betfair.com/horse-racing/paul-nicholls/">Paul Nicholls</a>
</li>
<li class="">
<a href="https://betting.betfair.com/horse-racing/bryony-frost/">Bryony Frost</a>
</li>
<li class="">
<a href="https://betting.betfair.com/horse-racing/news/">News</a>
</li>
<li class="">
<a href="https://betting.betfair.com/horse-racing/horseracing-tips/bets-of-the-day/">Bets of the Day</a>
</li>
<li class="">
<a href="https://betting.betfair.com/horse-racing/horseracing-tips/daily-racing-multiple/">Daily Racing Multiple</a>
</li>
<li class="">
<a href="https://betting.betfair.com/horse-racing/ante-post/">Ante-Post</a>
</li>
</ul>
</div>
</div>
</nav>
</li>
<li class="menu__item menu__item--active">
<a href="https://betting.betfair.com/betting/snooker/">Snooker</a>
</li>
<li class="menu__item">
<span class="menu__toggle">More</span>
<a href="https://betting.betfair.com/cricket/">Cricket</a>
<nav class="sub_menu">
<div class="sub_menu__wrapper">
<div class="sub_menu__block sub_menu__block--featured">
<h4>Featured Cricket</h4>
<ul>
<li>
<a href="https://betting.betfair.com/cricket/indian-premier-league---ipl/royal-challengers-bangalore-v-rajasthan-royals-tips-back-samson-to-lift-rajasthan-250422-646.html">Royal Challengers Bangalore v Rajasthan Royals: Back Samson to lift Rajasthan</a>
</li>
<li>
<a href="https://betting.betfair.com/cricket/indian-premier-league---ipl/punjab-kings-v-chennai-super-kings-ipl-tips-csk-should-have-the-smarts-240422-194.html">Punjab Kings v Chennai Super Kings IPL Tips: CSK should have the smarts</a>
</li>
<li>
<a href="https://betting.betfair.com/cricket/indian-premier-league---ipl/match-previews/lucknow-super-giants-v-mumbai-indians-ipl-tips-lucknow-rate-top-value-to-compound-mumbai-misery-220422-171.html">Lucknow Super Giants v Mumbai Indians IPL Tips: Lucknow rate top value to compound Mumbai misery</a>
</li>
</ul>
</div>
<div class="sub_menu__block sub_menu__block--more">
<h4>More Cricket</h4>
<ul>
<li class="">
<a href="https://betting.betfair.com/cricket/cricket-tips/">Cricket Tips</a>
</li>
<li class="">
<a href="https://betting.betfair.com/cricket/indian-premier-league---ipl/">Indian Premier League</a>
</li>
<li class="">
<a href="https://betting.betfair.com/cricket/pakistan-super-league/">Pakistan Super League</a>
</li>
<li class="">
<a href="https://betting.betfair.com/cricket/big-bash/">Big Bash</a>
</li>
<li class="">
<a href="https://betting.betfair.com/cricket/england-cricket/">England</a>
</li>
<li class="">
<a href="https://betting.betfair.com/cricket/australia-cricket/">Australia</a>
</li>
<li class="">
<a href="https://betting.betfair.com/cricket/india-cricket/">India</a>
</li>
<li class="">
<a href="https://betting.betfair.com/cricket/new-zealand-cricket/">New Zealand</a>
</li>
<li class="">
<a href="https://betting.betfair.com/cricket/south-africa-cricket/">South Africa</a>
</li>
<li class="">
<a href="https://betting.betfair.com/cricket/pakistan-cricket/">Pakistan</a>
</li>
<li class="">
<a href="https://betting.betfair.com/cricket/sri-lanka-cricket/">Sri Lanka</a>
</li>
</ul>
</div>
</div>
</nav>
</li>
<li class="menu__item">
<a href="https://betting.betfair.com/multiples/">Multiples Tips</a>
</li>
<li class="menu__item">
<span class="menu__toggle">More</span>
<a href="https://betting.betfair.com/tennis/">Tennis</a>
<nav class="sub_menu">
<div class="sub_menu__wrapper">
<div class="sub_menu__block sub_menu__block--featured">
<h4>Featured Tennis</h4>
<ul>
<li>
<a href="https://betting.betfair.com/tennis/events/atp-estoril-munich-outright-tips-schwartzman-justified-favourite-to-succeed-in-estoril-250422-778.html">ATP Estoril & Munich Outright Tips: Schwartzman justified favourite to succeed in Estoril</a>
</li>
<li>
<a href="https://betting.betfair.com/tennis/tennis-tips/atp-munich-tips-veteran-kohlschreibers-time-may-be-up-at-the-bmw-open-250422-169.html">ATP Munich Tips: Veteran Kohlschreiber's time may be up at the BMW Open</a>
</li>
<li>
<a href="https://betting.betfair.com/tennis/tennis-tips/atp-belgrade-tips-take-a-chance-on-kecmanovic-against-struggling-djokovic-200422-169.html">ATP Belgrade Tips: Take a chance on Kecmanovic against struggling Djokovic</a>
</li>
</ul>
</div>
<div class="sub_menu__block sub_menu__block--more">
<h4>More Tennis</h4>
<ul>
<li class="">
<a href="https://betting.betfair.com/tennis/australian-open-betting/">Australian Open</a>
</li>
<li class="">
<a href="https://betting.betfair.com/tennis/french-open-betting/">French Open</a>
</li>
<li class="">
<a href="https://betting.betfair.com/tennis/wimbledon/">Wimbledon</a>
</li>
<li class="">
<a href="https://betting.betfair.com/tennis/us-open/">US Open</a>
</li>
<li class="">
<a href="https://betting.betfair.com/tennis/events/">Events</a>
</li>
<li class="">
<a href="https://betting.betfair.com/tennis/atp-tour-finals-betting/">ATP Tour Finals</a>
</li>
<li class="">
<a href="https://betting.betfair.com/tennis/davis-cup-betting/">Davis Cup</a>
</li>
</ul>
</div>
</div>
</nav>
</li>
<li class="menu__item">
<span class="menu__toggle">More</span>
<a href="https://betting.betfair.com/golf/">Golf</a>
<nav class="sub_menu">
<div class="sub_menu__wrapper">
<div class="sub_menu__block sub_menu__block--featured">
<h4>Featured Golf</h4>
<ul>
<li>
<a href="https://betting.betfair.com/golf/golf-form-guide/catalunya-championship-2022-players-form-guide-240422-779.html">Catalunya Championship 2022: Your form stats for this week's event in north-east Spain</a>
</li>
<li>
<a href="https://betting.betfair.com/golf/the-punter/zurich-classic-of-new-orleans-result-and-review-pablo-in-seventh-heaven-250422-167.html">The Punter's De-Brief: Pablo in seventh heaven </a>
</li>
<li>
<a href="https://betting.betfair.com/golf/the-punter/the-punters-in-play-zurich-classic-of-new-orleans-tips-cantlay-and-schauffele-show-the-way-220422-167.html">The Punter's In-Play Blog: Can Pablo pounce for title number seven?</a>
</li>
</ul>
</div>
<div class="sub_menu__block sub_menu__block--more">
<h4>More Golf</h4>
<ul>
<li class="">

<a href="https://betting.betfair.com/golf/the-punter/">The Punter</a>
</li>
<li class="">
<a href="https://betting.betfair.com/golf/golf-bets/">Golf Bets</a>
</li>
<li class="">
<a href="https://betting.betfair.com/golf/european-tour/">DP World Tour</a>
</li>
<li class="">
<a href="https://betting.betfair.com/golf/pga-tour/">PGA Tour</a>
</li>
<li class="">
<a href="https://betting.betfair.com/golf/golf-form-guide/">Golf Form Guide</a>
</li>
<li class="">
<a href="https://betting.betfair.com/golf/us-masters/">US Masters</a>
</li>
<li class="">
<a href="https://betting.betfair.com/golf/the-open/">The Open</a>
</li>
<li class="">
<a href="https://betting.betfair.com/golf/us-open/">US Open</a>
</li>
<li class="">
<a href="https://betting.betfair.com/golf/us-pga-championship/">US PGA Championship</a>
</li>
<li class="">
<a href="https://betting.betfair.com/golf/ryder-cup/">Ryder Cup</a>
</li>
</ul>
</div>
</div>
</nav>
</li>
<li class="menu__item">
<span class="menu__toggle">More</span>
<a href="https://betting.betfair.com/politics/">Politics</a>
<nav class="sub_menu">
<div class="sub_menu__wrapper">
<div class="sub_menu__block sub_menu__block--featured">
<h4>Featured Politics</h4>
<ul>
<li>
<a href="https://betting.betfair.com/politics/french-politics/french-presidential-election-odds-betting-and-analysis-220422-171.html">French Presidential Election: Macron appears to be pulling clear</a>
</li>
<li>
<a href="https://betting.betfair.com/politics/uk-politics/politics-live-the-latest-odds-moves-tips-and-analysis-on-betfairs-politics-markets-110122-171.html">Politics Live: Johnson exit odds falling fast as MPs plunge the knife</a>
</li>
<li>
<a href="https://betting.betfair.com/politics/uk-politics/boris-johnson-to-leave-no-10-odds-pm-backed-to-leave-this-year-ahead-of-partygate-apology-190422-204.html">Boris Johnson To Leave No.10: PM backed to leave this year ahead of partygate apology</a>
</li>
</ul>
</div>
<div class="sub_menu__block sub_menu__block--more">
<h4>More Politics</h4>
<ul>
<li class="">
<a href="https://betting.betfair.com/politics/us-politics/">US Politics</a>
</li>
<li class="">
<a href="https://betting.betfair.com/politics/brexit/">Brexit</a>
</li>
<li class="">
<a href="https://betting.betfair.com/politics/uk-politics/">UK Politics</a>
</li>
<li class="">
<a href="https://betting.betfair.com/politics/general-election/">General Election </a>
</li>
 <li class="">
<a href="https://betting.betfair.com/politics/general-politics-betting/">General Politics Betting</a>
</li>
<li class="">
<a href="https://betting.betfair.com/politics/french-politics/">French Politics</a>
</li>
</ul>
</div>
</div>
</nav>
</li>
<li class="menu__item">
<span class="menu__toggle">More</span>
<a href="https://betting.betfair.com/specials/">Specials</a>
<nav class="sub_menu">
<div class="sub_menu__wrapper">
<div class="sub_menu__block sub_menu__block--featured">
<h4>Featured Specials</h4>
<ul>
<li>
<a href="https://betting.betfair.com/specials/spoty/bbc-sports-personality-of-the-year-2022-betting-tyson-fury-new-favourite-after-beating-dillian-whyte-250422-204.html">Sports Personality of the Year 2022: Tyson Fury new favourite after beating Dillian Whyte</a>
</li>
<li>
<a href="https://betting.betfair.com/specials/eurovision-song-contest/who-will-win-eurovision-2022-uk-up-with-the-favourites-210422-204.html">Who will win Eurovision 2022? UK are among the favourites</a>
</li>
<li>
<a href="https://betting.betfair.com/specials/oscars/oscars-2022-betting-power-of-the-dog-and-coda-in-thrilling-battle-for-best-picture-220322-204.html">Oscars 2022 Betting: Power of the Dog and Coda in thrilling battle for Best Picture</a>
</li>
</ul>
</div>
<div class="sub_menu__block sub_menu__block--more">
<h4>More Specials</h4>
<ul>
<li class="">
<a href="https://betting.betfair.com/specials/eurovision-song-contest/">Eurovision Song Contest</a>
</li>
<li class="">
<a href="https://betting.betfair.com/specials/oscars/">Oscars</a>
</li>
<li class="">
<a href="https://betting.betfair.com/specials/strictly-come-dancing/">Strictly Come Dancing</a>
</li>
<li class="">
<a href="https://betting.betfair.com/specials/mercury-music-prize/">Mercury Music Prize</a>
</li>
<li class="">
<a href="https://betting.betfair.com/specials/xfactor/">X-Factor</a>
</li>
<li class="">
<a href="https://betting.betfair.com/specials/celebrity-big-brother/">Celebrity Big Brother</a>
</li>
</ul>
</div>
</div>
</nav>
</li>
<li class="menu__item">
<span class="menu__toggle">More</span>
<a href="https://betting.betfair.com/rugby/">Rugby</a>
<nav class="sub_menu">
<div class="sub_menu__wrapper">
<div class="sub_menu__block sub_menu__block--featured">
<h4>Featured Rugby</h4>
<ul>
<li>
<a href="https://betting.betfair.com/rugby/rugby-union/six-nations-cheat-sheet-best-bets-for-wales-v-france-england-v-ireland-and-italy-v-scotland-010322-624.html">Six Nations Cheat Sheet: Best bets for Wales v France, England v Ireland and Italy v Scotland</a>
</li>
<li>
<a href="https://betting.betfair.com/rugby/rugby-union/six-nations-betting-france-odds-on-for-grand-slam-but-wales-and-england-await-030322-204.html">Six Nations Betting: France odds-on for Grand Slam but Wales and England await</a>
</li>
<li>
<a href="https://betting.betfair.com/rugby/rugby-union/six-nations-betting/six-nations-cheat-sheet-best-bets-for-england-v-wales-scotland-v-france-and-ireland-v-italy-180222-624.html">Six Nations Cheat Sheet: Best bets for England v Wales, Scotland v France and Ireland v Italy</a>
</li>
</ul>
</div>
<div class="sub_menu__block sub_menu__block--more">
<h4>More Rugby</h4>
<ul>
<li class="">
<a href="https://betting.betfair.com/rugby/rugby-world-cup/">Rugby World Cup</a>
</li>
<li class="">
<a href="https://betting.betfair.com/rugby/rugby-union/six-nations-betting/">Six Nations</a>
</li>
<li class="">
<a href="https://betting.betfair.com/rugby/rugby-league/super-league/">Super League</a>
</li>
<li class="">
<a href="https://betting.betfair.com/rugby/aviva-premiership/">Aviva Premiership</a>
</li>
<li class="">
<a href="https://betting.betfair.com/rugby/european-champions-cup/">European Champions Cup</a>
</li>
<li class="">
<a href="https://betting.betfair.com/rugby/rugby-league/">Rugby League</a>
</li>
<li class="">
<a href="https://betting.betfair.com/rugby/rugby-union/">Rugby Union</a>
</li>
</ul>
</div>
</div>
</nav>
</li>
<li class="menu__item">
<span class="menu__toggle">More</span>
<a href="https://betting.betfair.com/us-sports/">US Sports</a>
<nav class="sub_menu">
<div class="sub_menu__wrapper">
<div class="sub_menu__block sub_menu__block--featured">
<h4>Featured US Sports</h4>
<ul>
<li>
<a href="https://betting.betfair.com/us-sports/mlb/world-series-2022-odds-dodgers-favourites-as-baseball-season-begins-060422-204.html">World Series 2022 Odds: Dodgers favourites as baseball season begins</a>
</li>
<li>
<a href="https://betting.betfair.com/us-sports/nfl/super-bowl/super-bowl-predictions-and-tips-the-pick-of-the-prop-bets-with-mike-carlson-100222-815.html">Super Bowl Tips: The pick of the prop bets from Mike Carlson</a>
</li>
<li>
<a href="https://betting.betfair.com/us-sports/nfl/super-bowl/super-bowl-lvi-predictions-12-reasons-to-watch-the-bengals-v-rams-110222-1063.html">Super Bowl LVI: 12 reasons to watch the Bengals v Rams</a>
</li>
</ul>
</div>

<div class="sub_menu__block sub_menu__block--more">
<h4>More US Sports</h4>
<ul>
<li class="">
<a href="https://betting.betfair.com/us-sports/basketball/">Basketball</a>
</li>
<li class="">
<a href="https://betting.betfair.com/us-sports/mlb/">MLB</a>
</li>
<li class="">
<a href="https://betting.betfair.com/us-sports/nfl/">NFL</a>
</li>
<li class="">
<a href="https://betting.betfair.com/us-sports/us-sports-news/">US Sports News</a>
</li>
</ul>
</div>
</div>
</nav>
</li>
<li class="menu__item menu__item--active">
<span class="menu__toggle">More</span>
<a href="https://betting.betfair.com/betting/">Other Sports</a>
<nav class="sub_menu">
<div class="sub_menu__wrapper">
<div class="sub_menu__block sub_menu__block--featured">
<h4>Featured Other Sports</h4>
<ul>
<li>
<a href="https://betting.betfair.com/betting/snooker/world-snooker-championship-betting/match-previews/world-snooker-quarter-final-tips-bingham-to-maintain-strong-record-against-trump-260422-171.html">World Snooker Quarter Final Tips: Bingham to maintain strong record against Trump</a>
</li>
<li>
<a href="https://betting.betfair.com/betting/snooker/world-snooker-championship-betting/match-previews/world-snooker-championship-quarter-final-tips-williams-and-bingtao-to-serve-up-a-crucible-classic-250422-171.html">World Snooker Quarter Final Tips: Williams and Bingtao to serve up a Crucible classic</a>
</li>
<li>
<a href="https://betting.betfair.com/betting/snooker/world-snooker-championship-betting/match-previews/world-snooker-championship-day-9-tips-saengkham-well-up-to-giving-higgins-a-fright-230422-171.html">World Snooker Championship Day 9 Tips: Saengkham well up to troubling Higgins</a>
</li>
</ul>
</div>
<div class="sub_menu__block sub_menu__block--more">
<h4>More Other Sports</h4>
<ul>
<li class="">
<a href="https://betting.betfair.com/betting/athletics/">Athletics</a>
</li>
<li class="">
<a href="https://betting.betfair.com/betting/gaa-1/">GAA</a>
</li>
<li class="">
<a href="https://betting.betfair.com/betting/boxing/">Boxing</a>
</li>
<li class="">
<a href="https://betting.betfair.com/betting/darts/">Darts</a>
</li>
<li class="">
<a href="https://betting.betfair.com/betting/esports/">eSports</a>
</li>
<li class="">
<a href="https://betting.betfair.com/betting/ufc/">UFC</a>
</li>
</ul>
</div>
</div>
</nav>
</li>
</ul>
</nav>
</div>
</div> <nav id="features_navigation">
<ul class="features_navigation">
 <li class="features_navigation__item">
<a class="features_navigation__card" href="https://betting.betfair.com/football/premier-league/">Premier League Tips</a>
</li>
<li class="features_navigation__item">
<a class="features_navigation__card" href="https://betting.betfair.com/horse-racing/horseracing-tips/itv-races/">Tony Calvin Tips</a>
</li>
<li class="features_navigation__item">
<a class="features_navigation__card" href="https://betting.betfair.com/football/football-tips/">Daily Football Tips</a>
</li>
<li class="features_navigation__item">
<a class="features_navigation__card" href="https://betting.betfair.com/horse-racing/bets-of-the-day">Daily Racing Tips</a>
</li>
<li class="features_navigation__item">
<a class="features_navigation__card" href="https://betting.betfair.com/golf/pga-tour/">PGA Tour Golf Tips</a>
</li>
<li class="features_navigation__item">
<a class="features_navigation__card" href="https://betting.betfair.com/politics/uk-politics/politics-live-the-latest-odds-moves-tips-and-analysis-on-betfairs-politics-markets-110122-171.html">Politics Live Blog</a>
</li>
</ul>
</nav>
</header>
<div class="takeover_adverts">
<div class="takeover_adverts__main">
</div>
<div class="takeover_adverts__left">
</div>
<div class="takeover_adverts__right">
</div>
</div>

<main class="layout__main layout__main--padding">
<div class="features_nav_carousel">
<div class="features_nav_carousel__item">
<a class="features_nav_carousel__card" href="https://betting.betfair.com/football/premier-league/" style="background-image: url('//betting.cdnppb.net/Virgil VD and Mo Salah 1280.220x124.jpg');">
<div><h4>Premier League Tips</h4></div>
</a>
</div>
<div class="features_nav_carousel__item">
<a class="features_nav_carousel__card" href="https://betting.betfair.com/horse-racing/horseracing-tips/itv-races/" style="background-image: url('//betting.cdnppb.net/Copy of 1280x720_TONY_CALVIN.178x100.png');">
<div><h4>Tony Calvin Tips</h4></div>
</a>
</div>
<div class="features_nav_carousel__item">
<a class="features_nav_carousel__card" href="https://betting.betfair.com/football/football-tips/" style="background-image: url('//betting.cdnppb.net/Player kicking ball - 1280.220x124.jpg');">
<div><h4>Daily Football Tips</h4></div>
</a>
</div>
<div class="features_nav_carousel__item">
<a class="features_nav_carousel__card" href="https://betting.betfair.com/horse-racing/bets-of-the-day" style="background-image: url('//betting.cdnppb.net/Ascot blurred sprint finish 1280.220x124.jpg');">
<div><h4>Daily Racing Tips</h4></div>
</a>
</div>
<div class="features_nav_carousel__item">
<a class="features_nav_carousel__card" href="https://betting.betfair.com/golf/pga-tour/" style="background-image: url('//betting.cdnppb.net/Justin Thomas drive blue sky 1280.220x124.jpg');">
<div><h4>PGA Tour Golf Tips</h4></div>
</a>
</div>
<div class="features_nav_carousel__item">
<a class="features_nav_carousel__card" href="https://betting.betfair.com/politics/uk-politics/politics-live-the-latest-odds-moves-tips-and-analysis-on-betfairs-politics-markets-110122-171.html" style="background-image: url('//betting.cdnppb.net/Parliament.220x145.jpg');">
<div><h4>Politics Live Blog</h4></div>
</a>
</div>
</div>

<header class="entry_header">
<h1 class="entry_header__title">World Snooker Quarter Final Tips: Bingham to maintain strong record against Trump</h1>
<ul class="entry_header__meta">
<li><a href="https://betting.betfair.com/authors/paul-krishnamurty/">Paul Krishnamurty</a></li>
<li><time datetime="2022-04-25">25 April 2022</time></li>
</ul>
<script type="application/ld+json">
  {
    "@context": "http://schema.org",
    "@type": "Article",
    "headline": "World Snooker Quarter Final Tips: Bingham to maintain strong record against Trump",
    "name": "World Snooker Quarter Final Tips: Bingham to maintain strong record against Trump",
    "description": "Paul Krishnamurty previews the second pair of quarter-finals, starting this afternoon, involving Judd Trump, Stuart Bingham, John Higgins and Jack Lisowski...",
    "url": "https://betting.betfair.com/betting/snooker/world-snooker-championship-betting/match-previews/world-snooker-quarter-final-tips-bingham-to-maintain-strong-record-against-trump-260422-171.html",
    "mainEntityOfPage": "https://betting.betfair.com/betting/snooker/world-snooker-championship-betting/match-previews/world-snooker-quarter-final-tips-bingham-to-maintain-strong-record-against-trump-260422-171.html",
    "datePublished": "2022-04-25T23:28:00+01:00",
        "dateModified": "2022-04-26T00:28:00+01:00",
            "thumbnailURL": "https://betting.cdnppb.net/betting/Bingham1280.320x180.jpg",
        "articleBody": "Paul Krishnamurty previews the second pair of quarter-finals, starting this afternoon, involving Judd Trump, Stuart Bingham, John Higgins and Jack Lisowski... The final session of the second round saw Judd Trump defy an Anthony McGill comeback to progress and Jack Lisowski record the best win of his career, eliminating pre-tournament favourite Neil Robertson in a deciding frame. The draw is scheduled for these two old friends to meet in the final, as they have several times previously. Lisowski needs another career high  Before thinking seriously about that prospect, both face tough quarter-final hurdles. That was the first time in seven attempts that Lisowski has beaten Robertson and demonstrates a mark of his progress. Beating John Higgins at the Crucible would perhaps be more significant, given that he lost 13-1 when they met in the last-16 four years ago. Instinctively, Lisowski seems like the dream opponent for a player like Higgins. Too attacking and often careless. A potter and scorer, but not a tactician, and therefore vulnerable to arguably the best of all-time in that department. However he has won two of their six previous meetings so that theory is unproven. Nevertheless, I expect Higgins to take charge of this game at some stage and he may very well dominate from the outset. For the first leg of the daily double, back him to win 13-9 or better via the -3.5 Frame Handicap market and also 13-6, 13-7 and 13-8 in a correct score combo. Daily Double (£3 stake pays (£14.85)  Back John Higgins to win the -3.5 Frame Handicap @ 2.2Back Over 22.5 Frames in Trump v Bingham @ 2.25 The head-to-head between Trump and Stuart Bingham is closer than you might think - 9-7, and 81-78 in frames, to the former world number one who dominated snooker from 2018-2021. I&#039;m not at all convinced Trump&#039;s game right now resembles anything like that golden period. Trump is very beatable right now  The game against McGill was close and could easily have gone the other way, despite the Scot playing below his best for the first two sessions. Trump&#039;s game looks as it has throughout the season - 70%, at best. He&#039;s still good enough to win tournaments, as he has twice, but is not an attractive or reliable betting proposition at short odds-on. Bingham seems bound to bring his game as usual here. The 2015 champion has had a poor season too but is once again coming good at this venue, taking out another Crucible specialist, Kyren Wilson yesterday. As the head-to-head frame scores suggest, I&#039;m confident he&#039;ll keep this close. [1.8] about him winning ten frames, via the +3.5 Frame Handicap is the bet. Another side bet I like here is 3/1 about Bingham making three centuries. Last year he hit this target in every round from the last-48 through to the semis.  Follow Paul on Twitter @paulmotty",
            "image": {
      "@type": "ImageObject",
      "url": "https://betting.cdnppb.net/betting/Bingham1280.jpg",
        "height": 720,
        "width": 1280
          },
        "publisher": {
      "@type": "Organization",
      "name": "Betting.Betfair",
      "logo": {
        "@type": "ImageObject",
        "url": "https://betting.cdnppb.net/_v2/img/betfairlogoblack.png"
      },
      "url": "https://betting.betfair.com/"
    },
    "author": "Paul Krishnamurty"
  }
</script>
</header>
<div class="two_column_layout">
<main class="entry_main">
<div class="entry_img">
<img src="//betting.cdnppb.net/betting/Bingham1280.728x410.jpg" srcset="//betting.cdnppb.net/betting/Bingham1280.450x253.jpg 450w, 
                       //betting.cdnppb.net/betting/Bingham1280.600x338.jpg 600w, 
                       //betting.cdnppb.net/betting/Bingham1280.728x410.jpg 728w" alt="2015 World Snooker Champion Stuart Bingham">
<figcaption class="entry_img__caption">Stuart Bingham is on another strong Crucible run</figcaption>
</div>


<div class="entry_actions">
<div>
<a class="button button--dark" href="https://promotions.betfair.com/prs/exchange-acq-uk-bau-money-back20-newvi-generic?rfr=2573">Join</a>
</div>
<div>
<a class="button btn--market" data-market_full="https://www.betfair.com/sport/snooker/world-championship/stuart-bingham-v-judd-trump/314082997" data-contextual_info='{"blog_name":"UK Other Sports","category_label":"Match Previews","market_id":"https:\/\/www.betfair.com\/sport\/snooker\/world-championship\/stuart-bingham-v-judd-trump\/314082997","entry_title":"World Snooker Quarter Final Tips: Bingham to maintain strong record against Trump"}' href="https://www.betfair.com/sport/snooker/world-championship/stuart-bingham-v-judd-trump/314082997">View market</a>
</div>
<div class="entry_actions__social entry_actions__social--twitter">
<a href="https://twitter.com/intent/tweet/?text=World%20Snooker%20Quarter%20Final%20Tips%3A%20Bingham%20to%20maintain%20strong%20record%20against%20Trump&url=https%3A%2F%2Fbetting.betfair.com%2Fbetting%2Fsnooker%2Fworld-snooker-championship-betting%2Fmatch-previews%2Fworld-snooker-quarter-final-tips-bingham-to-maintain-strong-record-against-trump-260422-171.html" target="_blank" title="Twitter"><span class="sprite_icon sprite_icon--twitter">Twitter</span></a>
</div>
<div class="entry_actions__social entry_actions__social--facebook">
<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fbetting.betfair.com%2Fbetting%2Fsnooker%2Fworld-snooker-championship-betting%2Fmatch-previews%2Fworld-snooker-quarter-final-tips-bingham-to-maintain-strong-record-against-trump-260422-171.html" target="_blank" title="Facebook"><span class="sprite_icon sprite_icon--facebook">Facebook</span></a>
</div>
<div class="entry_actions__social entry_actions__social--reddit">
<a href="https://www.reddit.com/submit/?url=https%3A%2F%2Fbetting.betfair.com%2Fbetting%2Fsnooker%2Fworld-snooker-championship-betting%2Fmatch-previews%2Fworld-snooker-quarter-final-tips-bingham-to-maintain-strong-record-against-trump-260422-171.html" target="_blank" title="Reddit"><span class="sprite_icon sprite_icon--reddit">Reddit</span></a>
</div>
<div class="entry_actions__social entry_actions__social--whatsapp">
<a href="https://api.whatsapp.com/send?text=https%3A%2F%2Fbetting.betfair.com%2Fbetting%2Fsnooker%2Fworld-snooker-championship-betting%2Fmatch-previews%2Fworld-snooker-quarter-final-tips-bingham-to-maintain-strong-record-against-trump-260422-171.html" target="_blank" title="WhatsApp"><span class="sprite_icon sprite_icon--whatsapp">WhatsApp</span></a>
</div>
<div class="entry_actions__social entry_actions__social--telegram">
<a href="https://t.me/share/url?url=https%3A%2F%2Fbetting.betfair.com%2Fbetting%2Fsnooker%2Fworld-snooker-championship-betting%2Fmatch-previews%2Fworld-snooker-quarter-final-tips-bingham-to-maintain-strong-record-against-trump-260422-171.html&text=World%20Snooker%20Quarter%20Final%20Tips%3A%20Bingham%20to%20maintain%20strong%20record%20against%20Trump" target="_blank" title="Telegram"><span class="sprite_icon sprite_icon--telegram">Telegram</span></a>
</div>
</div>
<div class="entry_body has-odds">

<p class="entry_body__intro">Paul Krishnamurty previews the second pair of quarter-finals, starting this afternoon, involving Judd Trump, Stuart Bingham, John Higgins and Jack Lisowski...</p>

<div class="entry_body__quote">
<blockquote>"Trump's game looks as it has throughout the season - 70%, at best...he is not an attractive or reliable betting proposition at short odds-on."
<p><a href="https://www.betfair.com/sport/snooker/world-championship/stuart-bingham-v-judd-trump/314082997">Back Stuart Bingham to win the 3.5 Frame Handicap 6u @ <b class="inline_odds" title="4/5"><span class="inline_odds__decimal">1.8</span><span class="inline_odds__fractional inline_odds__tooltip">4/5</span></b></a><p></blockquote>
</div>

<div class="entry_body__content">
<div class="editor">
<p>The final session of the second round saw Judd Trump defy an Anthony McGill comeback to progress and Jack Lisowski record the best win of his career, eliminating pre-tournament favourite Neil Robertson in a deciding frame. The draw is scheduled for these two <strong>old friends</strong> to meet in the final, as they have several times previously.<h2>Lisowski needs another career high</h2><p></p><p>Before thinking seriously about that prospect, both face <strong>tough quarter-final hurdles</strong>. That was the first time in seven attempts that Lisowski has beaten Robertson and demonstrates a mark of his progress. Beating John Higgins at the Crucible would perhaps be more significant, given that he lost <strong>13-1</strong> when they met in the last-16 four years ago.</p><p>Instinctively, Lisowski seems like the <strong>dream opponent</strong> for a player like Higgins. Too attacking and often careless. A potter and scorer, but not a tactician, and therefore vulnerable to arguably the best of all-time in that department. However he has won two of their six previous meetings so that theory is unproven.</p><p>Nevertheless, I expect Higgins to take charge of this game at some stage and he may very well dominate from the outset. For the first leg of the daily double, back him to win 13-9 or better via the <a href="https://www.betfair.com/sport/snooker/world-championship/jack-lisowski-v-john-higgins/31408301">-3.5 Frame Handicap</a> market and also 13-6, 13-7 and 13-8 in a correct score combo.</p><h2>Daily Double (£3 stake pays (£14.85)</h2><p></p><p><strong>Back John Higgins to win the -3.5 Frame Handicap @ 2.2</strong><br><strong>Back Over 22.5 Frames in Trump v Bingham @ 2.25</strong></p><p>The head-to-head between Trump and Stuart Bingham is closer than you might think - 9-7, and <strong>81-78 in frames</strong>, to the former world number one who dominated snooker from 2018-2021. I'm not at all convinced Trump's game right now resembles anything like that golden period.</p><h2>Trump is very beatable right now</h2><p></p><p>The game against McGill was close and could easily have gone the other way, despite the Scot playing below his best for the first two sessions. Trump's game looks as it has throughout the season - 70%, at best. He's still good enough to win tournaments, as he has twice, but is <strong>not an attractive or reliable betting proposition</strong> at short odds-on.</p><p>Bingham seems bound to bring his game as usual here. The 2015 champion has had a poor season too but is once again coming good at this venue, taking out another Crucible specialist, Kyren Wilson yesterday. As the head-to-head frame scores suggest, I'm confident he'll keep this close. <b class="inline_odds" title="4/5"><span class="inline_odds__decimal">1.8</span><span class="inline_odds__fractional inline_odds__tooltip">4/5</span></b> about him winning ten frames, via the <a href="https://www.betfair.com/sport/snooker/world-championship/stuart-bingham-v-judd-trump/31408299">+3.5 Frame Handicap</a> is the bet.</p><p>Another side bet I like here is 3/1 about Bingham making three centuries. Last year he hit this target in every round from the last-48 through to the semis.</p><p></p><p><strong>Follow Paul on Twitter <a href="https://twitter.com/paulmotty" target="_blank" rel="noopener">@paulmotty</a></strong></p></p>
</div>
</div>




<div class="recommended_bets betslip_goto auto_banners" data-banner_cta="Join">
<h3>Recommended bets</h3>
<div class="editor editor--reversed">
<p>3 units double <p>
</p><p><a href="https://www.betfair.com/sport/snooker/world-championship/jack-lisowski-v-john-higgins/31408301">Back John Higgins to win the -3.5 Frame Handicap @ <b class="inline_odds" title="6/5"><span class="inline_odds__decimal">2.2</span><span class="inline_odds__fractional inline_odds__tooltip">6/5</span></b></a></p><p>
</p><p><a href="https://www.betfair.com/sport/snooker/world-championship/stuart-bingham-v-judd-trump/314082997">Back Over 22.5 Frames in Bingham v Trump @ <b class="inline_odds" title="5/4"><span class="inline_odds__decimal">2.25</span><span class="inline_odds__fractional inline_odds__tooltip">5/4</span></b></a></p><p>
</p><p><a href="https://www.betfair.com/sport/snooker/world-championship/jack-lisowski-v-john-higgins/31408301">Back John Higgins to win 13-6 1u @ <b class="inline_odds" title="12/1"><span class="inline_odds__decimal">13.0</span><span class="inline_odds__fractional inline_odds__tooltip">12/1</span></b></a></p><p>
</p><p><a href="https://www.betfair.com/sport/snooker/world-championship/jack-lisowski-v-john-higgins/31408301">Back John Higgins to win 13-7 1u @ <b class="inline_odds" title="11/1"><span class="inline_odds__decimal">12.0</span><span class="inline_odds__fractional inline_odds__tooltip">11/1</span></b></a></p><p>
</p><p><a href="https://www.betfair.com/sport/snooker/world-championship/jack-lisowski-v-john-higgins/31408301">Back John Higgins to win 13-8 1u @ <b class="inline_odds" title="10/1"><span class="inline_odds__decimal">11.0</span><span class="inline_odds__fractional inline_odds__tooltip">10/1</span></b></a></p><p>
</p><p><a href="https://www.betfair.com/sport/snooker/world-championship/stuart-bingham-v-judd-trump/314082997">Back Stuart Bingham to win the 3.5 Frame Handicap 6u @ <b class="inline_odds" title="4/5"><span class="inline_odds__decimal">1.8</span><span class="inline_odds__fractional inline_odds__tooltip">4/5</span></b></a></p><p>
</p><p><a href="https://www.betfair.com/sport/snooker/world-championship/stuart-bingham-v-judd-trump/314082997">Back Stuart Bingham to hit three centuries or more 2u @ <b class="inline_odds" title="3/1"><span class="inline_odds__decimal">4.0</span><span class="inline_odds__fractional inline_odds__tooltip">3/1</span></b></a></p><p>
</p></p>
</div>
</div>
<div id="betslip" class="entry_body__extras">
</div>
<div class="entry_body__widgets">
<div class="widget-context widget-context--both">
<div class="widget" data-context="both">
<div id="betnow-uk-widget" class="widget__body">
<h3><span style="color: white;">Get a Free £/€20</span> Exchange Bet</h3>
<ul>
<li><strong>Join Now</strong> - Open account using promo code <strong>VAL225</strong></li>
<li><strong>Bet</strong> - Place a £/€20 Bet on the Exchange</li>
<li><strong>Earn</strong> We'll Refund You £/€20 If the Bet Loses</li>
</ul>
<p><small>T&amp;Cs apply.</small></p>
</div>
<div class="widget__footer" style="margin-bottom: 1.5rem;"><a class="btn btn--market" href="https://promotions.betfair.com/prs/exchange-acq-uk-bau-free20-val225-temp" target="_blank">Bet now</a></div>
</div>
</div>
</div>

<div class="entry_actions">
<div>
<a class="button button--dark" href="https://promotions.betfair.com/prs/exchange-acq-uk-bau-money-back20-newvi-generic?rfr=2573">Join</a>
</div>
<div>
<a class="button btn--market" data-market_full="https://www.betfair.com/sport/snooker/world-championship/stuart-bingham-v-judd-trump/314082997" data-contextual_info='{"blog_name":"UK Other Sports","category_label":"Match Previews","market_id":"https:\/\/www.betfair.com\/sport\/snooker\/world-championship\/stuart-bingham-v-judd-trump\/314082997","entry_title":"World Snooker Quarter Final Tips: Bingham to maintain strong record against Trump"}' href="https://www.betfair.com/sport/snooker/world-championship/stuart-bingham-v-judd-trump/314082997">View market</a>
</div> </div>

<div class="entry_share">
<ul class="button_group">
<li class="button_group__twitter">
<a href="https://twitter.com/intent/tweet/?text=World%20Snooker%20Quarter%20Final%20Tips%3A%20Bingham%20to%20maintain%20strong%20record%20against%20Trump&url=https%3A%2F%2Fbetting.betfair.com%2Fbetting%2Fsnooker%2Fworld-snooker-championship-betting%2Fmatch-previews%2Fworld-snooker-quarter-final-tips-bingham-to-maintain-strong-record-against-trump-260422-171.html" target="_blank" title="Twitter"><span class="sprite_icon sprite_icon--twitter">Twitter</span></a>
</li>
<li class="button_group__facebook">
<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fbetting.betfair.com%2Fbetting%2Fsnooker%2Fworld-snooker-championship-betting%2Fmatch-previews%2Fworld-snooker-quarter-final-tips-bingham-to-maintain-strong-record-against-trump-260422-171.html" target="_blank" title="Facebook"><span class="sprite_icon sprite_icon--facebook">Facebook</span></a>
</li>
<li class="button_group__reddit">
<a href="https://www.reddit.com/submit/?url=https%3A%2F%2Fbetting.betfair.com%2Fbetting%2Fsnooker%2Fworld-snooker-championship-betting%2Fmatch-previews%2Fworld-snooker-quarter-final-tips-bingham-to-maintain-strong-record-against-trump-260422-171.html" target="_blank" title="Reddit"><span class="sprite_icon sprite_icon--reddit">Reddit</span></a>
</li>
<li class="button_group__whatsapp">
<a href="https://api.whatsapp.com/send?text=https%3A%2F%2Fbetting.betfair.com%2Fbetting%2Fsnooker%2Fworld-snooker-championship-betting%2Fmatch-previews%2Fworld-snooker-quarter-final-tips-bingham-to-maintain-strong-record-against-trump-260422-171.html" target="_blank" title="WhatsApp"><span class="sprite_icon sprite_icon--whatsapp">WhatsApp</span></a>
</li>
<li class="button_group__telegram">
<a href="https://t.me/share/url?url=https%3A%2F%2Fbetting.betfair.com%2Fbetting%2Fsnooker%2Fworld-snooker-championship-betting%2Fmatch-previews%2Fworld-snooker-quarter-final-tips-bingham-to-maintain-strong-record-against-trump-260422-171.html&text=World%20Snooker%20Quarter%20Final%20Tips%3A%20Bingham%20to%20maintain%20strong%20record%20against%20Trump" target="_blank" title="Telegram"><span class="sprite_icon sprite_icon--telegram">Telegram</span></a>
</li>
</ul>
</div>

<div class="fb-comments" data-href="https://betting.betfair.com/betting/snooker/world-snooker-championship-betting/match-previews/world-snooker-quarter-final-tips-bingham-to-maintain-strong-record-against-trump-260422-171.html" data-width="100%" data-numposts="10"></div>

<h3 class="section_title">Discover the latest articles</h3>
<ul class="related_entries">
<li>
<article>
<a href="https://betting.betfair.com/betting/snooker/world-snooker-championship-betting/match-previews/world-snooker-final-preview-and-tips-selby-to-prevail-after-another-marathon-020521-171.html">World Snooker Final Preview and Tips: Selby to prevail after another marathon</a>
<img src="//betting.cdnppb.net/betting/MarkSelby1280x720.728x410.jpg" alt="https://betting.betfair.com/betting/MarkSelby1280x720.jpg" loading="lazy">
</article>
</li>
<li>
<article>
<a href="https://betting.betfair.com/betting/snooker/world-snooker-championship-betting/match-previews/world-snooker-semi-final-tips-wilson-to-march-on-towards-his-Crucible-destiny-280421-171.html">World Snooker Semi-Final Tips: Wilson to march on towards his Crucible destiny</a>
<img src="//betting.cdnppb.net/betting/Bingham1280.728x410.jpg" alt="https://betting.betfair.com/betting/Bingham1280.jpg" loading="lazy">
</article>
</li>
<li>
<article>
<a href="https://betting.betfair.com/betting/snooker/world-snooker-championship-betting/match-previews/world-snooker-quarter-final-tips-bets-advised-in-all-four-matches-260421-171.html">World Snooker Quarter-Final Tips: Bets advised in all four matches</a>
<img src="//betting.cdnppb.net/betting/Kyren-Wilson-snooker-1280.728x410.jpg" alt="https://betting.betfair.com/betting/Kyren-Wilson-snooker-1280.jpg" loading="lazy">
</article>
</li>
</ul>
<h3 class="section_title">Read past articles</h3>
<ul class="related_entries">
<li>
<article>
<a href="https://betting.betfair.com/betting/snooker/world-snooker-championship-betting/match-previews/world-snooker-championship-quarter-final-tips-williams-and-bingtao-to-serve-up-a-crucible-classic-250422-171.html">World Snooker Quarter Final Tips: Williams and Bingtao to serve up a Crucible classic</a>
<img src="//betting.cdnppb.net/betting/Mark Williams.728x398.jpg" alt="https://betting.betfair.com/betting/Mark%20Williams.jpg" loading="lazy">
</article>
</li>
<li>
<article>
<a href="https://betting.betfair.com/betting/snooker/world-snooker-championship-betting/match-previews/world-snooker-championship-day-9-tips-saengkham-well-up-to-giving-higgins-a-fright-230422-171.html">World Snooker Championship Day 9 Tips: Saengkham well up to troubling Higgins</a>
<img src="//betting.cdnppb.net/betting/40e0225c7aff9115a9164f3fd585f25e9b947727.728x410.jpg" alt="https://betting.betfair.com/betting/40e0225c7aff9115a9164f3fd585f25e9b947727.jpg" loading="lazy">
</article>
</li>
<li>
<article>
<a href="https://betting.betfair.com/betting/snooker/world-snooker-championship-betting/match-previews/world-snooker-championship-day-8-tips-mcgill-can-at-least-run-trump-close-220422-171.html">World Snooker Championship Day 8 Tips: McGill can at least run Trump close</a>
<img src="//betting.cdnppb.net/betting/mcgill1280.728x410.jpg" alt="https://betting.betfair.com/betting/mcgill1280.jpg" loading="lazy">
</article>
</li>
</ul>

<div class="entry_category_link">
<a class="button" href="https://betting.betfair.com/betting/snooker/world-snooker-championship-betting/match-previews/">More Match Previews</a>
</div>
</div>
</main>
<aside class="entry_sidebar">
<section class="story-extra">
<nav class="sidebar_navigation">
<h4 class="section_title">More UK Other Sports</h4>
<ul class="sidebar_menu">
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/betting/german-masters/" class=" ">
German Masters
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/betting/olympics/" class=" ">
Olympics
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/betting/athletics/" class=" ">
Athletics
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/betting/boxing/" class=" ">
Boxing
</a>
</li>
<li class="sidebar_menu__item on sidebar_menu__item--has_children ">
<span class="sidebar_menu__toggle sidebar_menu__toggle--has_children "></span>
<a href="https://betting.betfair.com/betting/snooker/" class="active ">
Snooker
</a>
<ul class="sidebar_menu">
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/betting/snooker/masters/" class=" ">
Masters
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/betting/snooker/uk-snooker-championship/" class=" ">
UK Snooker Championship
</a>
</li>
<li class="sidebar_menu__item on sidebar_menu__item--has_children ">
<span class="sidebar_menu__toggle sidebar_menu__toggle--has_children "></span>
<a href="https://betting.betfair.com/betting/snooker/world-snooker-championship-betting/" class="active ">
World Snooker Championship
</a>
<ul class="sidebar_menu">
<li class="sidebar_menu__item on sidebar_menu__item--has_children ">
<span class="sidebar_menu__toggle sidebar_menu__toggle--has_children "></span>
<a href="https://betting.betfair.com/betting/snooker/world-snooker-championship-betting/match-previews/" class="active ">
Match Previews
</a>
<ul class="sidebar_menu">
</ul>
</li>
</ul>
</li>
</ul>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/betting/gaa-1/" class=" ">
GAA
</a>
</li>
<li class="sidebar_menu__item  sidebar_menu__item--has_children ">
<span class="sidebar_menu__toggle sidebar_menu__toggle--has_children "></span>
<a href="https://betting.betfair.com/betting/darts/" class=" ">
Darts
</a>
<ul class="sidebar_menu">
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/betting/darts/wayne-mardle/" class=" ">
Wayne Mardle
</a>
</li>
</ul>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/betting/esports/" class=" ">
eSports
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/betting/formula-one/" class=" ">
Formula One
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/betting/other/" class=" ">
Other
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/betting/tour-de-france/" class=" ">
Tour De France
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/betting/winter-olympics/" class=" ">
Winter Olympics
</a>
</li>
<li class="sidebar_menu__item   ">
<span class="sidebar_menu__toggle  "></span>
<a href="https://betting.betfair.com/betting/ufc/" class=" ">
UFC
</a>
</li>
</ul>
</nav>
</section>
<div class="widget-context widget-context--full">
<div class="widget" data-context="full">
<div class="lazy_widget"></div>
</div>
</div>
<div class="widget-context widget-context--full">
<div class="widget" data-context="full">
<div id="side-sport-text-ad" class="widget">
<div class="widget__body">
<h3>GET A FREE £/€20 EXCHANGE BET</h3>
<ul>
<li><strong>Join Now</strong> - Open Account Using Promo Code <strong>VAL225</strong></li>
<li><strong>Bet</strong> - Place a £/€20 Bet on the Exchange</li>
<li><strong>Earn</strong> - £/€20 Back in cash if your bet loses</li>
</ul>
</div>
<div class="widget__footer">
<a class="button grad_yellow" href="https://promotions.betfair.com/prs/exchange-acq-uk-bau-free20-val225-temp">BET & WIN</a>
</div>
</div>​
</div>
</div>
<div class="widget-context widget-context--full">
<div class="widget" data-context="full">
<div class="block"><header class="block__header"><h3>Services</h3></header><div class="block__body sidebar_navigation_ruled"><ul><li><a href="https://betting.betfair.com/how-to-use-betfair-exchange/beginner-guides/" target="_blank">Beginners' Guide to Betfair Exchange</a></li><li><a href="https://betting.betfair.com/betfair-announcements/whats-new-on-betfair/betfair-exchange-minimum-stake-were-lowering-it-to-1-020222-6.html" target="_blank">Minimum Exchange stake now £1 - details here</a></li><li><a href="https://betting.betfair.com/betfair-announcements/whats-new-on-betfair/opta-definitions-shots-and-shots-on-target-061020-204.html" target="_blank">Shots on Target - Definitions</a></li><li><a href="https://betting.betfair.com/horse-racing/horseracing-tips/money-back-if-your-horse-doesnt-finish-in-top-three-161121-204.html" target="_blank">Money Back if your horse doesn't place - T&Cs</a></li><li><a href="https://betting.betfair.com/betfair-announcements/whats-new-on-betfair/line-markets-on-betfair-everything-you-need-to-know-240821-204.html" target="_blank">Line Markets -Everything you need to know as NFL and NBA are added</a></li><li><a href="https://betting.betfair.com/betfair-announcements/whats-new-on-betfair/matchme-making-it-easier-get-your-bet-matched-260121-204.html" target="_blank">MatchMe - Making it easier to get your bet matched</a></li><li><a href="https://betting.betfair.com/golf/each-way-golf-betting-calculator/" target="_blank">Each-Way Betting Calculator</a></li><li><a href="https://betting.betfair.com/betfair-announcements/whats-new-on-betfair/my-betfair-rewards-choose-your-bonuses-with-new-feature-140619-6.html" target="_blank">My Betfair Rewards</a></li><li><a href="https://support.betfair.com/app/contact_us/" target="_blank">Betfair Customer Support</a></li><li><a href="https://betting.betfair.com/horse-racing/minimum-bet-guarantee-terms-and-conditions-190618-6.html" target="_blank">Minimum Bet Guarantee - Horse Racing</a></li></ul></div></div>
</div>
</div>
<div class="widget-context widget-context--full">
<div class="widget" data-context="full">
<div class="block"> <header class="block__header"><h3>Communities</h3></header> <div class="block__body block__body--light"> <ul class="button_group"> <li> <a href="https://twitter.com/betfairexchange" target="_blank"> <span class="sprite_icon sprite_icon--twitter">Twitter</span> </a> </li><li> <a href="https://www.facebook.com/Betfair" target="_blank"> <span class="sprite_icon sprite_icon--facebook">Facebook</span> </a> </li><li> <a href="https://www.youtube.com/channel/UC9XohsLvYWrUqkPUuR3mpTw?view_as=subscriber" target="_blank"> <span class="sprite_icon sprite_icon--youtube">YouTube</span> </a> </li><li> <a href="https://betting.betfair.com/index.xml"> <span class="sprite_icon sprite_icon--rss">RSS</span> </a> </li><li> <a href="https://www.instagram.com/betfair" target="_blank"> <span class="sprite_icon sprite_icon--instagram">Instagram</span> </a> </li><li> <a href="https://open.spotify.com/show/6Ev5q92RFgvWk49NcObn9c" target="_blank"> <span class="sprite_icon sprite_icon--spotify">Spotify</span> </a> </li><li> <a href="https://podcasts.apple.com/ie/podcast/betfair/id1463419538" target="_blank"> <span class="sprite_icon sprite_icon--apple_podcasts">Apple Podcasts</span> </a> </li><li> <a href="https://soundcloud.com/betfair-betting-podcast/" target="_blank"> <span class="sprite_icon sprite_icon--soundcloud">Soundcloud</span> </a> </li><li> <a href="https://podcasts.google.com/?feed=aHR0cDovL2ZlZWRzLnNvdW5kY2xvdWQuY29tL3VzZXJzL3NvdW5kY2xvdWQ6dXNlcnM6NjIyNDAzOTk0L3NvdW5kcy5yc3M" target="_blank"> <span class="sprite_icon sprite_icon--google_podcasts">Google Podcasts</span> </a> </li></ul> </div></div>
</div>
</div>
<div class="widget-context widget-context--full">
<div class="widget" data-context="full">
</div>
</div>
<div class="widget-context widget-context--full">
<div class="widget" data-context="full">
<h3 class="section_title" style="width: 100%; box-sizing: border-box;">Related Sites</h3><div><a href="https://tinyurl.com/n9kappa" target="_blank"><img src="/images/betfair-related.png" alt="Betfair" width="300" height="100" loading="lazy"></a></div><div><a href="https://www.timeform.com/horse-racing/" target="_blank"><img src="https://betting.betfair.com/images/timeform-related.png" alt="Timeform Horse Racing" width="300" height="100" loading="lazy"></a></div><div><a href="https://www.infogol.net/" target="_blank"><img src="https://betting.betfair.com/images/infogol-related.png" alt="Infogol" width="300" height="100" loading="lazy"></a></div>
</div>
</div>
<div class="widget-context widget-context--both">
<div class="widget" data-context="both">
<div class="block">
<header class="block__header"><h3>Archive</h3></header>
<div class="block__body sidebar_navigation_ruled">
<ul>
<li><a href="./archive/">View archives</a></li>
</ul>
</div>
</div>
</div>
</div>
</aside>
</div>

<nav class="breadcrumb__navigation">
<ol>
<li>
<a href="https://betting.betfair.com/">Home</a>
</li>
<li>
<a href="https://betting.betfair.com/betting/">Other Sports</a>
</li>
<li>
<a href="https://betting.betfair.com/betting/snooker/">Snooker</a>
</li>
<li>
<a href="https://betting.betfair.com/betting/snooker/world-snooker-championship-betting/">World Snooker Championship</a>
</li>
<li>
<a href="https://betting.betfair.com/betting/snooker/world-snooker-championship-betting/match-previews/">Match Previews</a>
</li>
<li>
World Snooker Quarter Final Tips: Bingham to maintain strong record against Trump
</li>
</ol>
</nav>
<script type="application/ld+json">
    {
      "@context": "http://schema.org",
      "@type": "BreadcrumbList",
      "itemListElement": [
                  {
            "@type": "ListItem",
            "position": 1,
            "item": {
              "@id": "https://betting.betfair.com/",
              "name": "Home"
            }
          },                  {
            "@type": "ListItem",
            "position": 2,
            "item": {
              "@id": "https://betting.betfair.com/betting/",
              "name": "Other Sports"
            }
          },                  {
            "@type": "ListItem",
            "position": 3,
            "item": {
              "@id": "https://betting.betfair.com/betting/snooker/",
              "name": "Snooker"
            }
          },                  {
            "@type": "ListItem",
            "position": 4,
            "item": {
              "@id": "https://betting.betfair.com/betting/snooker/world-snooker-championship-betting/",
              "name": "World Snooker Championship"
            }
          },                  {
            "@type": "ListItem",
            "position": 5,
            "item": {
              "@id": "https://betting.betfair.com/betting/snooker/world-snooker-championship-betting/match-previews/",
              "name": "Match Previews"
            }
          },                  {
            "@type": "ListItem",
            "position": 6,
            "item": {
              "@id": "https://betting.betfair.com/betting/snooker/world-snooker-championship-betting/match-previews/world-snooker-quarter-final-tips-bingham-to-maintain-strong-record-against-trump-260422-171.html",
              "name": "World Snooker Quarter Final Tips: Bingham to maintain strong record against Trump"
            }
          }              ]
    }
  </script>
</main>

<div class="full_navigation" id="full_navigation">
<div class="full_nav_link full_navigation__toggle"><span></span></div>

<nav class="full_navigation__menu full_navigation__menu--primary">
<ul class="menu">
<li class="menu__item">
<a href="https://betting.betfair.com/football/">Football</a>
</li>
<li class="menu__item">
<a href="https://betting.betfair.com/horse-racing/">Horse Racing</a>
</li>
<li class="menu__item menu__item--active">
<a href="https://betting.betfair.com/betting/snooker/">Snooker</a>
</li>
<li class="menu__item">
<a href="https://betting.betfair.com/cricket/">Cricket</a>
</li>
<li class="menu__item">
<a href="https://betting.betfair.com/multiples/">Multiples Tips</a>
</li>
<li class="menu__item">
<a href="https://betting.betfair.com/tennis/">Tennis</a>
</li>
<li class="menu__item">
<a href="https://betting.betfair.com/golf/">Golf</a>
</li>
<li class="menu__item">
<a href="https://betting.betfair.com/politics/">Politics</a>
</li>
<li class="menu__item">
<a href="https://betting.betfair.com/specials/">Specials</a>
</li>
<li class="menu__item">
<a href="https://betting.betfair.com/rugby/">Rugby</a>
</li>
<li class="menu__item">
<a href="https://betting.betfair.com/us-sports/">US Sports</a>
</li>
<li class="menu__item menu__item--active">
<a href="https://betting.betfair.com/betting/">Other Sports</a>
</li>
</ul>
</nav>
<nav class="full_navigation__menu full_navigation__menu--secondary">
<h3>More from Betfair</h3>
<ul class="menu">
<li class="menu__item">
<a href="https://betting.betfair.com">Betting.Betfair</a>
</li>
<li class="menu__item">
<a href="https://betting.betfair.com/podcasts/">Podcasts</a>
</li>
<li class="menu__item">
<a href="https://www.betfair.com/sport/">Betfair Sportsbook</a>
</li>
<li class="menu__item">
<a href="https://betting.betfair.com/how-to-use-betfair-exchange/">Exchange How-to</a>
</li>
<li class="menu__item">
<a href="https://www.betfair.com/exchange/plus/">Betfair Exchange</a>
</li>
<li class="menu__item">
<a href="https://responsiblegambling.betfair.com/">Safer Gambling</a>
</li>
</ul>
<ul class="menu">
<li class="menu__item">
<a href="https://register.betfair.com/account/registration?product=CIDF9QtQsFYf223X&amp;returnURL=https%3A%2F%2Fbetting.betfair.com%2Fbetting%2Fsnooker%2Fworld-snooker-championship-betting%2Fmatch-previews%2Fworld-snooker-quarter-final-tips-bingham-to-maintain-strong-record-against-trump-260422-171.html">Join</a>
</li>
<li class="menu__item">
<a href="https://identitysso.betfair.com/view/login?product=CIDF9QtQsFYf223X&amp;url=https%3A%2F%2Fbetting.betfair.com%2Fbetting%2Fsnooker%2Fworld-snooker-championship-betting%2Fmatch-previews%2Fworld-snooker-quarter-final-tips-bingham-to-maintain-strong-record-against-trump-260422-171.html">Log in</a>
</li>
</ul>
</nav>
</div>

<footer class="layout__footer">
<footer class="footer">
<div class="footer__column">
<p class="footer__text">WE ARE A SECURE OPERATOR | 18+ Gambleaware.co.uk
<br><br>
BETFAIR ® and the BETFAIR logo are registered trade marks of The Sporting Exchange Limited. ©The Sporting Exchange Limited. All rights reserved.
<br><br>
For customers in the UK, TSE Malta LP is licensed and regulated by the Gambling Commission, Licence Number: <a href="https://secure.gamblingcommission.gov.uk/PublicRegister/Search/Detail/39561" target="_blank">000-039561-R-319411-005</a>. Correspondence Address: Triq il-Kappillan Mifsud, St. Venera, SVR 1851, MALTA. Betfair International Plc is licensed and regulated by the <a href="https://www.mga.org.mt/" target="_blank">Malta Gaming Authority</a>. Licence Number: MGA/CL3/454/2008 17th March 2015, Triq il-Kappillan Mifsud, St. Venera, SVR 1851, MALTA. Fixed Odds & Multiples bets are placed with PPB Counterparty Services Limited which is licensed and regulated by the <a href="https://www.mga.org.mt/" target="_blank">Malta Gaming Authority</a>. Licence Number: MGA/CL2/294/2006 12 March 2013, and for customers in the UK, licensed and regulated by the Gambling Commission, Licence Number: <a href="https://secure.gamblingcommission.gov.uk/PublicRegister/Search/Detail/39439" target="_blank">000-039439-R-319330-007</a>.</p>
</div>
<div class="footer__column footer__column--links">
<div class="footer__links">
<h3>More Betfair</h3>
<ul>
<li><a href="https://betting.betfair.com/betfair-announcements/whats-new-on-betfair/my-betfair-rewards-choose-your-bonuses-with-new-feature-140619-6.html">My Betfair Rewards </a></li>
<li><a href="https://tvguide.betfair.com/english-uk/tv/">Live Sport on TV</a></li>
<li><a href="https://www.betfair.com/sport/cashout">Cash Out</a></li>
</ul>
</div>
<div class="footer__links">
<h3>More Betfair</h3>
<ul>
 <li><a href="https://tinyurl.com/mmbnsp7">Betfair Corporate</a></li>
<li><a href="https://support.betfair.com/app/answers/detail/a_id/5749/">Payment Methods</a></li>
</ul>
</div>
<div class="footer__links">
<h3>About</h3>
<ul>
<li><a href="https://www.betfair.com/aboutUs/Privacy.Policy/">Privacy Policy</a></li>
<li><a href="https://www.betfair.com/aboutUs/Cookie.Policy/">Cookie Policy</a></li>
<li><a href="https://tinyurl.com/mmbnsp7">About Betfair</a></li>
<li><a href="https://support.betfair.com/app/home">Help &amp; Learning</a></li>
<li><a href="https://responsiblegambling.betfair.com/">Safer Gambling</a></li>
</ul>
</div>
<div class="footer__links">
<h3>Pick language</h3>
<ul>
<li><a href="https://betting.betfair.com/">Global</a></li>
<li><a href="https://apuestas.betfair.es">Español</a></li>
<li><a href="https://scommesseonline.betfair.it/">Italia</a></li>
<li><a href="https://apostas.betfair.com/">Português</a></li>
<li><a href="/dk/">Danmark</a></li>
<li><a href="https://betting.betfair.com/se/">Sverige</a></li>
<li><a href="https://pariuri.betfair.ro" http: pariuri.betfair.com />România</a></li>
</ul>
</div>
</div>
</footer>
<div class="small_print">
<div class="small_print__text">
<p>For any queries relating to Betting.Betfair, e-mail <a href="mailto:Copy@betfair.com">Copy@betfair.com</a>. For any other Betfair-related queries, head to <a href="https://support.betfair.com/app/home" target="_blank">customer support</a></p>
<p>&copy; Betfair 2007&ndash;2022</p>
</div>
</div>
</footer>

<nav id="floating_nav">
<ul><li><a href="https://betting.betfair.com/football//"><strong>Latest</strong> Football</a></li><li><a href="https://betting.betfair.com/horse-racing/"><strong>Latest</strong> Horse Racing</a></li><li><a href="https://betting.betfair.com/golf/"><strong>Latest</strong> Golf</a></li><li><a href="https://betting.betfair.com/cricket/"><strong>Latest</strong> Cricket</a></li></ul>
</nav>
</div>

<script type="text/javascript">
/*
$(document).ready(function(){
let slidesToKeep = ['.fri'];
  $('.festival_page_carousel--races').slick('slickFilter', String(slidesToKeep));
});*/
</script>
<script defer src="https://static.cloudflareinsights.com/beacon.min.js/v652eace1692a40cfa3763df669d7439c1639079717194" integrity="sha512-Gi7xpJR8tSkrpF7aordPZQlW2DLtzUlZcumS8dMQjwDHEnw9I7ZLyiOj/6tZStRBGtGgN6ceN6cMH8z7etPGlw==" data-cf-beacon='{"rayId":"701b68a4bb935704","token":"d048f65d27954a24aa6b1d7d2ddcb256","version":"2021.12.0","si":100}' crossorigin="anonymous"></script>
</body>
</html>
